Trying to Install 8.1.2 just getting index of directory

I’ve set up a new ubuntu 22.04 server with php, apache2 and mysql.

I’ve followed the install instructions but when I point a browser at https:///suitecrm all I get is a listing of the suitecrm directory on the web server.

The only command from the install instructions that failed was

chmod +x bin/console

which returns - chmod: cannot access ‘bin/console’: No such file or directory

I’ve tried the cli installation but that returns the same error.

I assume I must be doing something stupid, as other people are able to install but I can’t work out what.

Any help would be appreciated.

Hey awservs


Are you still having issues with this?

Currently, I’m not entirely sure what the issue may be
But do you perhaps see a “/public/” folder when you are shown the SuiteCRM folder contents?

like so:

If so, can you click into this, and let us know what you see?

(hopefully, it should be the UI of SuiteCRM8, but please let us know if not)

Hi John, sorry for the delayed response but life…

OK I finally managed to get SuiteCRM working. First I moved the whole thing into the root of the web-server which I think sorted out any issues with Apache not loading any site specific configurations.

Then I being served a blank html page with no content. I tried a CLI installation which threw a few errors.

Whilst trying to debug these errors I realised that out of the box (off the memory stick?) Ubuntu 22.04 install php 8.1 which isn’t supported by SuiteCRM. Downgrading to 8.0 fixed the issues.

I did read the pre-requisites but that didn’t jump out at me! Next I must try and move it into a sub-directory on the web server and see if it stills runs.