Trouble Deploying on Local Instance...Looking for Log

So I’ll lead this off by saying I know very little about the mechanics of SuiteCRM but I’m in a position that I need to take more of this on so my organization can move forward. I’ve recently setup docker and I am able to pull down and launch SuiteCRM locally. For the most part everything looks and feels fine.

Then, when I go to module builder and make a change…when I attempt to deploy that change I just get stuck on the deploying screen and it just spins forever. Obviously I don’t expect anyone to know the problem just from this but is there some sort of log or error file for the deploy process that would clue me in on what is happening?


I’m suspecting the issue is related to file permissions.

Check here for more info on that:

1 Like

Thank you. I did try to set the file permissions but still the same issue. I think I should take a step back and explain what I’ve done because now as I’m thinking through it, I definitely think I’ve missed a step.

I’ll apologize for my ignorance in advance but that is why I’m here. I’m running Ubuntu and I am serving locally using docker. In docker, I have two containers, one for the app and one for the database. I have pulled our repository down and I am able to successfully serve SuiteCRM. Meaning I can login, I can create data in the existing tables. Most things seems to work. But, when I attempt to deploy from module builder, it just spins constantly. The goal with serving locally is to be able to make modifications to the modules and custom php files. Do any necessary testing before pushing back into the repo and deploying to our dev environment and eventually production.

I had a ‘duh’ moment today and I went back to Ubuntu to check and found our I didn’t have php or mysql installed. So I installed those but the same issue is still in effect.

At this point I assume I have made an incorrect assumption as to how this would work and I’m sure I’ve just completely skipped the necessary steps.

To check why the deploying process is not working, Go to the admin page and click on “System Settings”.

After clicking on System Settings->Choose Log Level is “Fatal” in “Logger Settings” and Save.

Now Delete your suitecrm.log file in the root of your instance

And again deploy your module from module builder and check suitecrm.log is updated with any error. Please share your suitecrm.log file screenshot, so we can check regarding the error.

Ok, the saga continues. I deleted the log file and attempted to deploy with the same result. The suitecrm.log file came back but it is empty.

Sounds like you have create permissions, but not write permissions.

Check also that .htaccess is not blocking you.

Or Selinux, if you have it.

And check who owns the files, not just permissions - the two things go together.

So in an effort to see if it was permissions on the log file I gave read write access to everyone:

-rwxrwxrwx 1 www-data www-data 0 Aug 31 22:02 suitecrm.log

No change on the overall problem. Here is an interesting tidbit. If I look in the module where I’ve made a change, the file is being modified when I attempt to deploy.


Please give us some context here, what is your Linux, your PHP version, your SuiteCRM version?

Can you check also your php_errors.log?