SuiteCRM-master install halt

Hello everybody.
I am completely new to CRM and lefthanded when it comes to linux. I am not new to hosting, email and dns. But I am not able to get this solved alone. Ok, what have I done.

I started a few days by an installation of sugarCRM CE and I didn’t like it. (It was an automatic installation via Installatron.) Everything that is nice was gone in the CE version.
I am not willing to pay $365 per user/year. So I searched or I could install all the nice things myself, to get to the same result. I already soon discovered that it was quite a bit more complicated than just that.

I was happy that I did find this website. After some searching to get familiar with what was all going on, I downloaded the latest version update and the latest full install from the website and later also from github. Since the project is so new, my thought was lets get the latest possible. First I searched for upgrading. I could not find out how to do it. Also I don’t like upgrades. Why start with a mess? There was not data in the CRM, so just start all over.

First I unpacked and uploaded, the normal version full install. It was not a good idea to do it that way. The file should have been uploaded as a zip and unpacked at the server. Ok, it’s a learning process and I did not find a good instruction that get’s a newbe by the hand from a-z to get it installed. I deleted everything and uploaded the git version. Unpacked, moved the content to the directory where I wanted it to be and tried to install. Many errors. After some confusing information about file permissions, different document saying different things. My latest try did give some result and the least errors, so I think I am getting closer. Before my latest try I did try a full recursive permission change to all the files to 666. After that I did a full recursive directory change to 777, including the folder where the files and directories of suiteCRM resides. I did this, because after a previous installation I did notice that most files I was the owner of. Just a few files it was apache that was the owner and I did read in one of the instructions that in such case the rights needed to be changed to prevent installation errors. But also that document was not very clear. It could be I changed too much permissions away from the default 755.

Ok, that was the intro so that you know the background.
I use a virtual server. I have wildcard support for subdomains active on my domain.
I made also (Just to be sure) the subdomain (office) in the dns. The server automatically creates a subfolder in the root of the public_html with the name of the subdomain (office). I run a .htaccess in the root of public_html to direct the domains and subdomains to the corresponding folders. Because of the wildcard everything ends up in the root, so it needs to be directed.

In the subdomain folder I have a subfolder where I run suiteCRM from. I did not put suiteCRM directly in the subdomain root because I want to run several scripts from this subdomain. I placed them in the subfolder crm. Also did I not point the .htaccess directly to the crm folder, because it is a subfolder within a subdomain.
To get the domain and subdomain working, I point them to the subfolders where the actual website resides. So far it is working.

Ok. Files are in place, I have all the info needed and I started an advanced install via the browser.
The joy was only short because after all what I tried, I am out of ideas how to get it installed.

I copied the information from the install screen, including the errors I have. (I replaced the username and domain name)

Perform Setup
Creating SuiteCRM configuration file (config.php)

Creating SuiteCRM application tables, audit tables and relationship metadata

Warning: Invalid argument supplied for foreach() in /home/accountname/domains/ on line 89

Warning: Invalid argument supplied for foreach() in /home/accountname/domains/ on line 85

Creating default SuiteCRM data

 Creating default users...   done
 Creating default scheduler jobs...   done

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(modules/TableDictionary.php/SugarFeeds/) is not within the allowed path(s): (/home/accountname/:/tmp:/var/tmp:/usr/local/lib/php/:/nfs/home/accountname/:/home/accountname/) in /home/accountname/domains/ on line 203

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(modules/BeanDictionary.php/SugarFeeds/) is not within the allowed path(s): (/home/accountname/:/tmp:/var/tmp:/usr/local/lib/php/:/nfs/home/accountname/:/home/accountname/) in /home/accountname/domains/ on line 203

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(custom/modules/logic_hooks.php/SugarFeeds/) is not within the allowed path(s): (/home/accountname/:/tmp:/var/tmp:/usr/local/lib/php/:/nfs/home/accountname/:/home/accountname/) in /home/accountname/domains/ on line 203

Sorry for my long post. But I thought that my non standard setup might be of influence with the installation.
Any help is very much appreciated.


There we are again. One day further.
To my surprise, when I today tried the or installation from yesterday was working, it was, well sort of.
I tried repairing and it crashed on using too much memory. End of story. The crash corrupted the installation.

After that I deleted everything. Installed CE by using Installatron and tried to run the upgrade process. It run into all kind of file restriction errors. Strange enough, the automated install by installatron does work and so did the user interface, but there are many files with wrong permission settings.
I did run a full recursive 666 on all files. After that a full recursive 777 on all directories. The upgrade wizard did start. I could upload the file and run the pre-installation tests. It run again into permission errors. This time on the session files.
Too bad that the check does not tell what kind of permission it expects. It only does show what the current setting is.
After trying several permissions I had one that worked for me. All files on 766 in the session directory. The session directory itself is 777.
I managed to install the upgrade.
After the installation, everything was a mess. The markup of the screen was not working. After again setting all the permissions, it did work for me.
The only thing that does not seem to work (Maybe there is more, but not discovered yet) is selecting themes. I see in the themes folder that there are 3 theme directories: Sugar5, Suite7 and default. In the admin interface, under themes I see 2x default …


I just went through the process and I can tell what I’ve learned to help you refine your methods.

  1. If you don’t have existing data to migrate - Start with the Full 7.0.1 SuiteCRM. - Don’t both with Sugar CE + SuiteCRM Upgrade. This way you’ll have some demo data to play with. ( Looks like you’ve done this)

  2. Upload the Zip to Root or your site then do a full extraction:
    a) Caution - Just to make the process easier, I would not install in subdomains of your VPS. SuiteCRM is most like perfectly comfortable with this but let’s start with a very manageable baseline.

3)After extracting the zip you’ll need at minimum the following 755 chdmod Permissions:

a) SuiteCRM (root Folder)
b) All first level subfolders
c) All first level files.

Note: Even though the default of 777 is less restrictive, the installer has a problem with this so stick with 755.

  1. Make sure you’ve got your database (name/user/password) setup. You did not mention what you’re using?

  2. Pay careful attention to the amount of memory allocated to PHP. The install script failed and I did not realize it since it did not capture these exceptions and print a failure message. I realized after examining the database since there was no demo data.

a) my system is currently executing the full SuiteCRM runtime with 64MB. I can’t remember but I think I had to bump it up either 128MB or 256MB to get over the threshold and install the demo database. This is located in your PHP.ini file if you have access to it. I’m note sure but it sounds like you have a VPS that you are managing.

I know these details are discussed in very general terms, I hope some of these may be of service.


Hi Scott,

thanks for your reply.

The whole installation and getting familiar with sugarCRM / suiteCRM is a learning process. And while I continue I see that there are many people having problems with permissions and ownership of files and directories related to the program.

As you could read in my opening message, did I also try to install a full suitecrm at first. I did not manage, and that is why I did try an upgrade over a by the system installed version of sugarCRM CE. Of Course I prefer a clean and fresh install above an upgrade path.

I did try the default 755 already in the beginning. (It was the default. It did not work.)
I managed with quite some trouble to get an upgrade installed by repeatedly taking ownership and changing permissions to 777 of all the files and have it more or less running. But not without errors. After I received your reply, I did try it out on the installation. Directly the whole program stopped functioning. Maybe it does work normally, but not on this environment.

You wrote to me that I might have used demo data. I did not.
Yes I do have database info, how could I else try to install it myself? :slight_smile: Without database, no installation. The database is MySQL.

And the environment is indeed a VPS. (Linux)
By the knowledge I have gained so far, I think the solution might be in two things.

By having a few lines of code in the config_override.php: This solves the session problems and hopefully also the permission problems. I think that these two solutions will solve all the problems I have.

$sugar_config['session_dir'] = 'sess/';
$sugar_config['default_permissions']['user'] = 'apache';
$sugar_config['default_permissions']['group'] = 'apache';
$sugar_config['default_permissions']['dir_mode'] = '02770';  // 02770 is 775 permission for directories on Centos Linux distro.
$sugar_config['default_permissions']['file_mode'] = '0660'; // 0660 is 664 permission for files on Centos Linux distro.

755 for all other directories
644 for all other files
But or these settings will work, depend on the environment of my hosting provider. I did send them an email to ask about it.
I am waiting for an answer to hear what the recommended settings are for their environment.

If that will not work, I will try these settings:

$sugar_config['default_permissions']['user'] = 'useracount';
$sugar_config['default_permissions']['group'] = 'useraccount';
$sugar_config['default_permissions']['dir_mode'] = '1411';  // 1411 is 777 permission for directories on Centos Linux distro.
$sugar_config['default_permissions']['file_mode'] = '1232'; // 1232 is 666 permission for files on Centos Linux distro.

755 for all other directories
644 for all other files

I did find some resource limitations that can be put into effect via the config_override.php, but they have only effect while the system is running already. I did not see such things for during the installation. Since I run it on a VPS, I cannot change the php settings.

If the system seems not to be able to be installed or run on their system, I will consider to rent another hosting place for the software. I am already for years with them and I would like to stay with them.

Thanks for thinking with me.

Claudio Bosgraaf


Sorry for the redundant information, but I just wanted to make sure I understood what was going on from your message.

If I understand this correctly you are having mostly runtime issues at this point with SuiteCRM. If so here are some additional suggestions:

  1. Take a look at the system logfile called “sugarcrm.log” which is usually located in the root directory. We may get some additional clues here.
  2. From the admin | system settings panel | Display stack trace of errors.

Last, Will has mentioned changing ownership using “sudo chown -R www-data:www-data” you may/maynot have



After many days and hours experimenting, reading many fora and comments about the installation process and tweaks, working at the top of my understanding and knowledge of linux (I am not a linux man), trying to get first sugarCRM and then suiteCRM successful and without errors running on my shared hosting server, I finally gave up. I was very frustrated, that despite my pitbull mentality, I could not get it done.

I decided to make use of vTiger, also a fork of sugarCRM and started for the same reasons.

Now I am using vTiger, to my and many others horror, vTiger is doing the same as sugarCRM. They became commercial and their open source version is not updated well anymore. Errors are plenty in the open source version. While in the paid version, they are getting solved. Also much functionality is being removed from the open source version. So the reason why the vTiger came to life, is now serving the standards of the vTiger team.

If I could get it running, I would gladly use suiteCRM. But the installation difficulty level, is beyond my knowledge. It seems to be a problem that all sugarCRM based products face. Whenever I read about the installation, everybody complains about the complicated installation and very special demands on user, directories and files permissions, and tweaks that needs to be made here and there, to get it up and running.

suiteCRM and vTiger are offered via installatron, to install it automatically on my server. That works fine.
Sadly, suiteCRM is not in the list of programs to execute an automatic installation for.

Is there anybody that could offer an installation that could be used for installatron? (
Or any other way to get it installed automatically, with just a few questions being asked.

Thanks in advance,


Hi Claudio, who is your hosting provider?

I already asked the or they can install it for me, when I pay for it, but they can’t.
So I also contacted Installatron, ( or they can add suiteCRM to their package base.
They will look into it.