SuiteCRM Email Client Error


Not sure if this is the right forum to ask for, but I have a strange behaviour when using internal SuiteCRM Email Editor.

Here’s what I try to do:

  • Open a contact
  • Click on contact’s email address
  • The email editor openes with broken layout and empty form fields (except the mail account to send from) -> Pls see attachment

What I expect:

  • after clicking the email address the editor opens and shows up with the contact’s email address in corresponding form field

What I did before:
I updated from 7.9.4 to 7.9.9 (pretty sure it did not work before either, so updating was the first thing I was trying)
After update it still didn’t work…

So I set up SuiteCRM 7.9.9 from scratch (full install package, new database) and import the formerly backed database.
Now I had a clean setup with “old” data in database.
Still the same error.

3rd idea was to setup a brand new and clean SuiteCRM with also clean database. Making a baseline setup and creating a contact by hand led me to a clean create email window.
Now, when clicking on contact’s email address, the opening window looks clean and is already filled with the contact’s email address as expected.

So, I think it could be a problem with the “old” imported database. Maybe it is corrupt or something else.

So my question is:
What can I do to resolve this issue?
How can I cleanup the database without losing data?
Or is there any other I could do to get rid of that behaviour?

Any help is appreciated.


P.S.: @board admin: If this is the wrong board pls feel free to move it to the right place. Thx

Did you export and import the database in the same SuiteCRM version?

Because if you exported in one version, then imported in a more advanced version, there could be database differences that are breaking the app.

I see several ways to approach this:

1 - on a non-functional system, simply try deleting all mail accounts, then recreating them, to see if it fixes anything

2 - go over the process again, but do a clean install of the same version, then import, only then upgrade

3 - with your latest, cleanest, working install, try to import individual tables of the data that matters most to you. That is, if you don’t have very complex data.

Which would you rather try?

1 Like

[quote=“pgr” post=58662]Did you export and import the database in the same SuiteCRM version?

Because if you exported in one version, then imported in a more advanced version, there could be database differences that are breaking the app.

To behonest, this is an error following me I think since we upgraded from 7.7 to 7.9.
But this time (first try) I did not export from older version and imported to newer (7.9.5 -> 7.9.9). But I’m pretty sure that I never did that export import thing during upgrade.
Export import (second try) was done because first try didn’t solve the problem :frowning:

Tried that, but no changes…

It’s a 7.9.5 which isn’t available at the download page. Any ideas where to find?

I have a fully running productive system so this is not possible. Lot of data will be lost…

I tried almost the whole day to examin the problem within database and also php files.

I’ve searched for problems within database tables, exported contacts list from 7.9.5 and imported into 7.9.9 (some import errors “NOTICE”, but worked)

I think there’s something wrong when calling the Email UI from contacts form. Same probs when opening from accounts form.


If you want to try option 2, you can find all the installers here

When you finish your process and upgrade to the latest, go straight to 7.9.10 which is out today, and includes email bugfixes.

If you want to try and dig deeper and find the root cause of your issue, have you looked in suitecrm.log and php_errors.log?

I tried something different now:

  • I’ve created a new user within my old 7.9.5 installation and tried to send email as described.

And voila, it works well. So this might be a permission problem?

When error occurs, I’m logged in as admin user, test profile is regular user…

Any ideas?

Is that the same email account details you’re using in both cases?

There were bugs (already fixed in the latest) where it was using an incorrect “From” address, taken from a different account. Some servers will allow a bogus “From” address, others won’t, and will give an error.

If you can simply upgrade to 7.9.10 (if you can’t find it yet, wait a few hours and retry), that could solve everything.

Another piece of advice that might solve a lot of mysteries for you is to try and use this debugging procedure:

1 Like

I took the same email account, yes.
But I don’t think it is a problem of sending emails.

It starts, when clicking on an email link either in contact or account (both, list or detail view)
Then the email form is already broken as shown in very first attachment.

I’ve tried to send email from both the “working” and the “broken” account:

  • “working” sends the email
  • “broken” fails and results in what I call “ugly form” as shown in the second attachment…

As said, when using “working” test account and also the original SuiteCRM admin profile, it works like charm…

BTW: I do not see any errors in php_errors.og and suitecrm.log

That is quite weird. When the screen breaks, you should have some browser error in your browser Developer console.

Maybe you should try a few options from Admin / Repair, namely QR&R and then some others mentioning Javascript.

If necessary, you can also delete cache/themes and it will be recreated. See if that solves anything.

1 Like

Damn, I’ve finally found it!!!

It was the email signature I’ve set.

I didn’t use the default signature but created a custom.

It started with:


firstname lastname

The two dashes at the beginning caused it.
And using the developer console was the clue.
When I checked it for errors during opening that email form, it said

" unknown …

Removed the dashes made it work again!!!


Many many thanks for bringing me on the right track!

This is quite treacherous!

Can you please try and break our demo here with that trick? :slight_smile:

If you succeed, can you please open an Issue on Github with this problem?

Anyway, congratulations on solving this!