SuiteCrm 8: problems with customizations

I also tried following the second method, but nothing changes, maybe I’m doing something wrong, but I followed the instructions, created folders and files

extensions/myext/config/module_routing.php

entering the given instructions, deleted the contents of suitecrm8/cache and did a Q&R, nothing, it doesn’t work

Try logging something in the code to check if it’s running.

(or the naughty way - provoke a FATAL and try to break PHP - if it’s a test server, of course)

I inserted a
GLOBAL['log']->fatal('Hello');
both in my custom code and in module_routing.php, but it never runs

What about php_errors.log, does it say anything during QR&R?

I am only responding now because I do not have access to folders other than the project and had to retrieve the PHP log.
There are no errors reported inside, the only thing I see, from firefox page analysis, is that it does not find the file

public/legacy/cache/jsLanguage/en_us.js?v=W_OuJ5JYKqaJ50RzJRt1UA

But it is present, so I don’t think that is the problem.
It’s driving me crazy. Unfortunately, if SuiteCRM 8 does not allow me to use the customizations made up to version 7.12, the new version becomes useless to me and I will have to stop at 7.12.

This is trickier than you would think. Here’s my personal instructions to activate legacy mode on a module. It does work…

go to:

config/services/module/module_routing.yaml

then repair→rebuild in admin ./bin/console cache:clear from cli

First of all, if you want it to use the legacy module set it to “false”, it seems counterintuitive as it’s called “legacy module routing” you’d expect it to be the opposite.

ALSO… all the module names in the file are in lower case ie: “accounts” when they are actually “Accounts” in SuiteCRM, so if you have a custom module, you’d expect it to be lower case. You’d be wrong. I have “PLNE_Planes” module and you have to enter it exactly as it is in SuiteCRM custom modules folder.

ALSO… do not “tab” in the file to line up the columns, will not work. Space bar only.

1 Like

Yes, I also followed these instructions, but nothing changes, it still doesn’t work

hmm… did you repair and rebuild an flush the cache from cli after you made the changes to the yaml file? That’s an important step. Also, it’s VERY tricky, you can only use spaces, no TAB. and make sure the formatting is perfect. I remember trying like 5-6 times to get it right.

I did not access the cli folder, but as instructed I deleted the suitecrm/cache folder… I wrote the names of the custom modules in both lower and upper case, avoided using TAB… I followed all the steps, but it doesn’t work

so clearing cache from the cli - … I have access through cPanel / terminal… what would the commands look like from there to clear the cache? Otherwise there are a bunch of different cache folders so… hesitant there… I have:
root/.cache (contains esbuild, node, yarn)
root/public_html/cache (contains prod)
think I came across another one or so as well… so which do we delete everything out of to test this?

Like this…

You have to do a cache clear AND repair and rebuild

That command on cPanel → Terminal, doesn’t work… tried pathing to the console but it’s a file and doesn’t open… Suggestions?

Did you put “php” in front of it?

nope ha… that’d do it… thanks for the simple reminder!

1 Like

well, that cleared the cache… but still isn’t routing the custom module through the yaml file into the suite 7 layout so I can add new buttons.

I have the below added to the module_routing.yaml file

SVCS_ServiceNotes:
      index: true
      list: false
      record: false

did a cache clear, did a repair/rebuild … but still not showing up… thoughts?

Sorry, I had a doubt… published this post because I didn’t see the customizations in my form:

  • js file that calculates the hours in an interval
  • the controls on the various fields through entrypoints

    but the custom module I see it independently of editing the module_routing.yaml file and clearing the cache.
    So my question, the modification of the module_routing.yaml file and clearing the cache, is it just to be able to see My custom module? If so, I don’t need it.

I would like to know how to get the js and entrypoints working again.

That looks right, unfortunately I don’t have the dev environment anymore where I set this up. I did in fact get it to work. I’ll send you a PDF of my personal notes on what I did to get it to work.

One other thing, did you copy the whole file to the extension, or just add your custom module?

I copied the whole file and then added my module at the end of it.

I modified the original file, what path would I throw the override file into for this? I’ve done a lot with custom/modules/ * and such, but wasn’t sure where this file would fall.

Just for S&G … cleared cache on the browser and refreshed… and it’s 7 style now!!!

now just to fine tune the Print PDF button to call back to the PDF template!! Thank you!!

1 Like