SuiteCRM 8 Beta - Install Questions

Hi @maxonss,

Thanks for the feedback.

@pgr is right.

I think Plesk’s default apache user is not www-data, have a look at:

1 Like

Hello @pgr,

OMG… I completely forgot to mention that we use Git Plesk’s extension to fetch code from our repo on Github ! What a shame to forget something that important.

When I try to install SuiteCRM after a simple drag & drop to the server, it obviously works following the installation guide.

However, when I use ps -ef it’s www-data that indeed runs the server.

www-data  1057115  384245  0 16:58 ?  00:00:00 /usr/sbin/apache2 -k start

EDIT : Just reinstalled the Plesk image and trying to find out what’s going on with the Git fetch… Maybe I’m just ignoring some files that I shouldn’t ignore.

EDIT 2 to clarify the context: We initialized a .git locally and linked it onto a remote. We pushed the SuiteCRM project before the installation and fetched it on the distant server from the remote. After the fetch on the distant server, I then add by hand the default .env and extension/ folder before trying to install via SSH

Hi @maxonss,

Is the code on the git repo, the code that came from the “pre-built” zip package? or does it come from the SuiteCRM-Core repo?

Do you commit everything? or are you ignoring parts of it?

Greetings @clemente.raposo,

I’m using the SuiteCRM-Core Beta 3 release from Github.

I’m now ignoring nothing but the files already ignored by the .gitignore located in the repo and then committing everything to the Git before fetching from the Plesk server.

I reinstalled the same Plesk image, installed the needed php extensions and followed the developer installation guide :

Permissions still the same for the cache/ folder :

root@domain $ ls -al
$ drwxrwsr-x    3 www-data               www-data   4096 Sep 22 12:32 cache

And user seems to be www-data after using ps -ef :

root@domain $ ps -ef
$ www-data  455907     892  0 14:26 ?        00:00:00 /usr/sbin/apache2 -k start

And I still have the same error :

Hi @maxonss,

Thanks for the feedback, this is really strange.

Is the cache/dev folder created already? If not, is SuiteCRM/Symfony able to create it?

Hi @clemente.raposo,

Sorry for long time without any answer.
Just wanted to thank you for your time, I re-mounted the VPS image and waited for the Release Candidate to come out and the prebuilt version now works great.

Thank you again,

EDIT: To answer the question you asked, Symfony was not able to create it, I think it was due to modified privileges I missed or something like that I could have broke during my tests… Sorry I cannot help.

Tried again with same result. Not able to connect to DB.

env.local file has following details.


Legacy settings are the same as SuiteCRM 8 Beta - Install Questions - #32 by cherub-chum

I am on Mac using MAMP PRO and the URL which points to crm is http://localhost:8888/suitecrm8/

Document Root is set to suitecrm8/public folder

how can we use a different port than default 3306? changing .env.local file directly will take effect?
Also there is no config.php file in public/legacy/ folder, would that be needed?

Hi @cherub-chum,

Thanks for the feedback.

About the above. At the moment you need to change both .env.local and public/legacy/config.php. We’ve already had a discussion about this internally and we will most likely add it to the installer soon.

About not being able to connect to the db:

@maxonss was also having issues with that. @maxonss if I’m not mistaken you were able to overcome that issue right?

The links on the following post may help also.

Yep, but I’m afraid that wasn’t about the port but the domain I used…

My problem was solved by using instead of localhost

7 posts were merged into an existing topic: Suite 8 : Installing on NGINX

16 posts were split to a new topic: Htaccess causing errors after install

Hi @clemente.raposo ,

I got this error while trying to access [suitecrm_root]/public. Can you please help? I’ve got no relevant errors in httpd log and suitecrm.log

2 posts were split to a new topic: Suite 8 : Customising Top Nav theme

3 posts were split to a new topic: Suite 8: change logs from new backend to stdout

@samus-aran @clemente.raposo

As the traction and interest for SuiteCRM 8 grows, it’s probably time to have a sub-forum for it, and not a single thread for all installation issues. This one now has 177 replies, which essentially means nobody is reading all of it anymore… having separate threads would make things easier to search.


I second that - too.

2 posts were split to a new topic: Suite 8 : Installing on NGINX

3 posts were split to a new topic: Suite 8 : Lost CSS

Alrighty folk,

This massive thread has served it’s purpose. Thanks @clemente.raposo for responding to everyone. We’ll close this thread, any new issues/install questions we ask you to open them up in the Install & Upgrade category (Installation & Upgrade Help - SuiteCRM) with the tag suitecrm8

Thanks everyone for your activity and providing us feedback to help us improve SuiteCRM 8 :tada: