SuiteCRM 8 Beta - Install Questions

Hi again,

Thank you very much for your fast answer.

Yes, I tried both methods, locally and to a distant server, I really can’t see what I’m missing… I followed exactly what the documentation says

  • Unzip the SuiteCRM Beta 3 folder into the root directory
  • Set the permissions (tried mutiple [user:group])
  • Run ./bin/console suitecrm:app:install
    (From this step, the console says that SuiteCRM Cli install failed but the legacy’s succeded)

After having set the permissions again, I set my root folder to public/ and nothing is showing now.

Same thing when installing from the repo…

I’m checking the logs trying to see something new…
Thank you again

Hi @maxonss,

Thanks for the feedback.

From first glance it seems that suite is not able to write to those folders.

Are there any logs on public/legacy/suitecrm.log that seem relevant?

One thing to have in mind is that the Beta 3 zip (unlike the Beta 2) has an inner folder inside the zip, where the beta 2 had the project files directly on the root level of the zip.

How does your structure look like from the root? is SuiteCRM 8 (core, cache, etc) directly on the root folder?

Hello @clemente.raposo !

Thank you again,

Are there any logs on public/legacy/suitecrm.log that seem relevant?

The only thing that I can see is in suitecrm.log is this :

Tue Sep 14 12:05:48 2021 [56724][-none-][FATAL] Could not connect to DB server http as root. port //localhost/: 

Here is what my folder looks like as Suite/ is part of the root directory of my virtual host (Suite/public/) :

Do you think the failure comes from permissions ?

Hi @maxonss,

From the log message seems a different thing. Suite is not able to reach the db.

Could you try using instead of localhost (or whatever the host is), please? Sometimes localhost is assumed as the socket connection.

Maybe also worth checking if there is any other db setup config that maybe missing

1 Like

Hello @clemente.raposo,

I tried to set as the database host name and the only thing that changed is that I can see a Symfony debugger bar at the bottom of the project now :

Errors still the same :

Step 1: Config Creation Complete
Starting SuiteCRM CLi Installation
SuiteCRM CLi Install Failed
Step 2: Legacy Installation Complete
Thu Sep 16 08:28:35 2021 [65586][-none-][FATAL] Could not connect to DB server localhost as root. port 3306: No such file or directory

Database still not created…

It looks like I’m not using the correct mysql as I’m running SuiteCRM via Mamp Pro.

Installation script ./bin/console suitecrm:app:install may be using the mysql installed by hand via the command line and not the one used by Mamp Pro ?
I’m currently looking for a way to find out which one is used (mysql).

Thank you very much for your help, I hope to find out what I’m missing

Hi @maxonss,

I don’t have much experience with MAMP pro, though maybe the these threads may help:

Not sure if there is any security risk in disabling the options they talk about.

Hope this helps

Hey @clemente.raposo,

Thank you for the resources you gave me, it helped a bit.

Just succeed the install using the “pre-built” package, I don’t know WHY it now works, but I think it could be because I deleted the mysql I installed using brew before, still using instead of localhost.

Here’s the history of the CLI install :

SuiteCRM Silent Install

Please enter the db username: root
Please enter the db password:
Please enter the db host:
Please enter the db name: suite8
Please enter the admin username: max
Please enter the admin password: ***
Please enter the suite 8 address: http://dev.suite8/
Install demo data:
  [0] yes
  [1] no
 > 1

Step 1: Config Creation Complete
Starting SuiteCRM CLi Installation
SuiteCRM CLi Install Complete
Step 2: Legacy Installation Complete

I will update this post when I’ll figure out how I succeed in the install, hoping it’ll help some people in the same situation.

Hi @maxonss,

Great! Very glad to know that you were able to install.

And yes, it would help a lot if you could share the root cause of the problem.


Just figured out that it may have worked because I changed localhost to (or whatever associated IP address) following @clemente.raposo’s advice.

Many thanks,

Hello again,

I am really sorry I have to ask for help again… I can’t find the issue nowhere and it seems to be about permissions, for real this time :

Symfony debugger tells me that it’s Unable to write in the “cache” directory :

Also tells me sometimes that it cannot open a file in append mode.

Here are the permissions set into the cache/ folder (server running Ubuntu) :

root@hungry-darwin:/var/www/vhosts/[domain_name]/httpdocs# ls -al cache/
total 12
drwxrwsr-x  3 www-data www-data 4096 Sep 21 11:25 .
drwxrwsr-x 13 www-data www-data 4096 Sep 21 11:49 ..
drwxrwsr-x  2 www-data www-data 4096 Sep 21 13:59 dev

I set the permissions again, just after launching the install ./bin/console suitecrm:app:install

I also tried to create the folder it was asking for by hand but nothing helped.

Symfony debugger also told that mkdir(); couldn’t be executed so it reinforces the idea that it’s surely a permission issue.

Thank you everyone for your time

Hi @maxonss,

How is your system setup? Are you using docker, vagrant or plain VM? Or is it just a regular ubuntu server?

Hello @clemente.raposo,

I’m using a VPS running Ubuntu and powered by Plesk and I have access to the server via SSH

Use ps -ef to check which user your web server is running under. If it’s not “www-data” you need to change ownerships.


Hi @maxonss,

Thanks for the feedback.

@pgr is right.

I think Plesk’s default apache user is not www-data, have a look at:

1 Like

Hello @pgr,

OMG… I completely forgot to mention that we use Git Plesk’s extension to fetch code from our repo on Github ! What a shame to forget something that important.

When I try to install SuiteCRM after a simple drag & drop to the server, it obviously works following the installation guide.

However, when I use ps -ef it’s www-data that indeed runs the server.

www-data  1057115  384245  0 16:58 ?  00:00:00 /usr/sbin/apache2 -k start

EDIT : Just reinstalled the Plesk image and trying to find out what’s going on with the Git fetch… Maybe I’m just ignoring some files that I shouldn’t ignore.

EDIT 2 to clarify the context: We initialized a .git locally and linked it onto a remote. We pushed the SuiteCRM project before the installation and fetched it on the distant server from the remote. After the fetch on the distant server, I then add by hand the default .env and extension/ folder before trying to install via SSH

Hi @maxonss,

Is the code on the git repo, the code that came from the “pre-built” zip package? or does it come from the SuiteCRM-Core repo?

Do you commit everything? or are you ignoring parts of it?

Greetings @clemente.raposo,

I’m using the SuiteCRM-Core Beta 3 release from Github.

I’m now ignoring nothing but the files already ignored by the .gitignore located in the repo and then committing everything to the Git before fetching from the Plesk server.

I reinstalled the same Plesk image, installed the needed php extensions and followed the developer installation guide :

Permissions still the same for the cache/ folder :

root@domain $ ls -al
$ drwxrwsr-x    3 www-data               www-data   4096 Sep 22 12:32 cache

And user seems to be www-data after using ps -ef :

root@domain $ ps -ef
$ www-data  455907     892  0 14:26 ?        00:00:00 /usr/sbin/apache2 -k start

And I still have the same error :

Hi @maxonss,

Thanks for the feedback, this is really strange.

Is the cache/dev folder created already? If not, is SuiteCRM/Symfony able to create it?

Hi @clemente.raposo,

Sorry for long time without any answer.
Just wanted to thank you for your time, I re-mounted the VPS image and waited for the Release Candidate to come out and the prebuilt version now works great.

Thank you again,

EDIT: To answer the question you asked, Symfony was not able to create it, I think it was due to modified privileges I missed or something like that I could have broke during my tests… Sorry I cannot help.

Tried again with same result. Not able to connect to DB.

env.local file has following details.


Legacy settings are the same as SuiteCRM 8 Beta - Install Questions - #32 by cherub-chum

I am on Mac using MAMP PRO and the URL which points to crm is http://localhost:8888/suitecrm8/

Document Root is set to suitecrm8/public folder

how can we use a different port than default 3306? changing .env.local file directly will take effect?
Also there is no config.php file in public/legacy/ folder, would that be needed?