Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

SuiteCRM 8: 503 Error

I’ve tried repeatedly to install SuiteCRM 8, and I keep getting 503 errors… I’m sure I am doing something wrong, but I don’t know what.

When I run the installer, I get the “installation complete” message, and I can see the files have been created…

This is an otherwise vanilla Ubuntu 20.04 LTS VPS (KVM). I’m using PHP 7.4 with pfp-fpm. I know the webserver “works” since if I create an index.html file manually, it loads.

I installed LAMP and the following modules. I’ve also enabled mod_rewrite.


php-imagick php7.4-fpm php7.4-mysql php7.4-common php7.4-gd php7.4-imap php7.4-json php7.4-curl php7.4-zip php7.4-xml php7.4-mbstring php7.4-bz2 php7.4-intl php7.4-gmp

My virtualhost file is

<VirtualHost *:80>
  ServerName mycrm.mycrm.com
  DocumentRoot /var/www/html/mycrm/



  <Directory />
    Options FollowSymLinks
    AllowOverride All
  </Directory>

  <Directory /var/www/html/mycrm/>
    Options FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
  </Directory>

Include /etc/apache2/conf-available/php7.4-fpm.conf

</VirtualHost>

it’s not really feasible for me to share the entire configuration, but there is the top part.