SuiteCRM 7.7.6 and Kreports 4.1.0 not work

Hi. I’m trying to deploy KReports 4.1.0 to SuiteCRM 7.7.6. The installation it’s ok, but when I go to module option and try to create a report, can’t select any module, the module selector it’s gray and not show anything.

I follow the instructions from, enable mod_rewrite in apache and install KRest module.

I’ve check the owner and all files are 775 security.

My enviroment is LAMP, Debian 8, PHP 7, MySQL 5.7.15.

Any idea?

Best regards.

Since KReports is an external addon, not maintained by Sales Agility, developers of SuiteCRM, I think you should ask this question in the SpiceCRM support portal or forums, if they give support to SuiteCRM, they should know your answer.

best regards

1 Like

Same issue here with 7.7.4. Can’t select modules.

Hi Mike and thanks.

I was contact with SpiceCRM team and they said:

I cannot speak for SuiteCRM. Typically there should be no issues since the SuiteCRM guys did not really change anything and thus SuiteCRM is basically a SugarCRM 6.5. The issue you are describing sounds like an issue with KRest and the rewrite engine.

I’ve tested KREST following the instructions of installation guide, and all it’s ok.

I think than Kreports it’s a great product, but they guys have not much interest on SuiteCRM support…


I’ve used KReport in the past, 3 years ago when was only a Facebook page managed by the owner, never tried the version 4.X when they joined forces with SpiceCRM. Back then you wouldn’t need any REST, I’ll give it a try and report back to you and I suggest to you to give a try to this module that I use it over the SuiteCRM standard report module

best regards

1 Like

I’m a big fan of KReports. I can highly recommend it. Even the free version is very powerful. And the owner (Christian Knoll) has been very helpful in the past with some minor issues.

My Krest sysinfo test (KREST/sysinfo) gives me the following:


Looks ok to me…

Me too be a big fan of KReports

This is my sysinfo KREST


It’s ok.

I believe it was a bug in packaging KREST 2.5.1 … please download KREST 2.5.2 from our wenbiste at and install and then check again.

I reset file permission. no luck.

I’m only seeing errors in log like:

Tue Nov 15 12:39:06 2016 [18146][1][WARN] Image icon_KReports_32.png not found
Tue Nov 15 12:39:06 2016 [18146][1][WARN] Image icon_KReports_32.png not found
Tue Nov 15 12:39:06 2016 [18146][1][WARN] Image KReports.gif not found

Kreporter team just answer my question…

it might be a packaging issue with the KREST Interface. Please download 2.5.2 from our website and install it. let me know if that fixed it.

Just install it and now can select module!

just to set things straight … kreporer has never been just a facebook page operated by the owner … there always has been a company behind it. The history is more that it grew out of customer requirements to provide an enterprise grade reporting tool.

When it comes to SuiteCRM it might be benficial if you guys adopt our KREST Interface and package it as standard part of your product. That woudl allow users to more easily consume our reporting which seems to be popular amonst your users. They can then also easily use our mobile app that can be found on the play stopre and app store and also out Outlook Plugin.

All of the above use the KREST Api. And I believe you guys anyway need a nicer REST API. Greg contacted me once but never sure where he left it then with this.

I’ve just tested and is working for me

KRest Core 2.5.2
KReporter Base 4.1.0
KReporter Core 4.1.0
SuiteCRM 7.7.7
PHP 7.0.8
Ubuntu 16.04.3
MySQL 5.7.16
Apache 2.4.18

I can select all modules when creating a report

best regards

1 Like

Hey everybody!

SpiceCRM just released a lightning fix upon our inquiry. You need to download the new version of the KRest CORE package (2.5.2).Mike already got the new one.

It now works for me!

Thanks SpiceCRM team!

Once again my lack of English skills strikes back, @spicecrm I didn’t ment to say that in a bad way, I just wanted to highlight that I’ve known KReporter for a long time, and was using it when we were working with SugarCRM

I remember that we started using AlineaSOL Reports because they released export to Excel when in KReporter was a paid feature, I don’t know about today.

There still are many reports that are only possible to achieve with KReporter and when this is need, we are using it.

I wish you best of luck with your projects and I hope to see KRest and SuiteCRM join forces, and I’m sorry if I sounded differently from what I wanted to explain.

PD: i’m not affiliated or part of Sales Agility, developers and maintainers of SuiteCRM, I’m just a regular user that likes to help

Best regards

Hi all,
I have installed SuiteCrm last stable Version 7.8.5 (
Sugar Versione 6.5.24 (Build 509)) and then following packages:


but while kreporter works normally I get an error adding a kreport dashlet on the homepage dashboard:

I have created a simple report and activate the publish option as presentation and visualization too.

Then when I try add the report dashlet in any of two modes and I receive this error from console and can’t select any report (view image below):

Uncaught TypeError: Cannot read property ‘options’ of null (KReportDashlets.js:13)

Looks like at this point i get the error because b.dashlet object in json retrieved from https://suitecrm.xxxx/KREST/KReporter/plugins/action/kpublishing/getDashletData is empty and in KReportDashlets.js:13

            method: "POST",
            url: "KREST/KReporter/plugins/action/kpublishing/getDashletData",
            params: {
                dashletid: this.dashletID
            success: function(a) {
                var b = Ext.decode(a.responseText);
                b.dashlet.options.title .....

{“dashlet”:null,“reports”:[{“id”:“1713270c-a384-4e6f-ad8f-01757c991a80”,“name”:“new Report”},{“id”:“10a54c83-2f84-4b55-b6fe-4be64c8499c5”,“name”:“Test Report for Home”}],“filters”:[]}

It looks like public/modules/KReports/Plugins/Integration/kpublishing/controller/pluginkpublishingcontroller.php
the method action_getDashletData return no dashlet data because $current_user global variable is empty and so when

    global $current_user, $db;
    $dashlets = $current_user->getPreference('dashlets', 'Home');

therefore dashlet is always null
Any one faced with the same issue?

Kind Regards