SuiteCRM 7.6.6(from CE6.52) Upgrade Wizard stalls to 500 error

I have an SuiteCRM 7.6.6 that is an upgraded SugarCRM CE 6.52 install.

Trying to use the Upgrade Wizard to update it to 7.8.3

  1. Click on “Upgrade Wizard” in the admin screen
  2. page starts to load but never gets to next step but results in an 500 Error page.

Error log shows nothing
UpgradeWizard log just contains:

Fri, 26 May 2017 15:06:23 -0500 [UpgradeWizard] - setting session variables...
Fri, 26 May 2017 15:06:23 -0500 [UpgradeWizard] - -----------------------------------------------------------------------------
Fri, 26 May 2017 15:06:23 -0500 [UpgradeWizard] - Upgrade started. At start.php
Fri, 26 May 2017 15:06:23 -0500 [UpgradeWizard] - at unlinkUWTempFiles()

Running php 7 (5.6 same results)
Memory increased to 512m
Timeouts to 300
php errors logged
increased max upload and post size

chmod the cache folder to 777 recursively

Seem’s to be stalling at unlinkUWTempFiles


I figured it out.

There was a bunch of junk (old installer files, etc) in the cache/upgrades/ folder

Just used an FTP client to delete them - everything installed fine,

Do you see any files with incorrect ownership in your directories? For example, is suitecrm.log owned by root?

That would explain the difficulties in deleting files (that’s what “unlink” means in PHP).

If you have these wrong ownerships it’s probably caused by running your cron jobs as a wrong user (it should be your web server’s user).

1 Like

Thanks - it was all the junk in the cache/upgrade folder that was the culprit.

Ah, I think I didn’t make myself clear - sorry. I had read your post explaining that your problem was solved by clearing the folder, my concern was if you could have a deeper underlying problem (a very common one I see on these forums a lot), that could cause you further problems in the future.

I think it’s worth investigating, but of course it’s up to you to decide. I’m glad you solved your original problem and thanks for sharing the solution!