SuiteCRM 7.13.2 src and 8.2.4 install on PHP 8.1

Complete newbie to SuiteCRM but an experienced dev, though somewhat new to php.

I am on MAMP 5.0.0 (windows) & PHP 8.1 (not 8.0.1).

I downloaded 7.13.2 and 8.2.4 to try the CRM. Followed the standard process, db & user create, give permissions and then went to browser to setup the app after having setup the url in httpd.conf.

After installing various modules required in both versions, I proceeded in the browser where it instructed me to run “composer install”. After passing that hurdle and passing "MS defender crap eating 70% CPU) by increasing the composer timeout to 2000, finally the 7.x showed up install screen. While at the step of installing DB, it gave 500. Log file showed it was looking for status.json which wasn’t there. Note that the parent folder has FULL permissions running under my admin account. Still I manually created that json to satisfy it. Went ahead and then 500 again. Log file indicated tons of css files missing errors. I gave up.

For the 8.2.4 version, I proceeded with composer install; this time, it told me to run composer update. It finished and showed the install screen but by excitement was shattered when on the install screen after giving all correct inputs, it showed “blank error popup in red”. Log suitecrm.log is empty while the deprecated.log has tons of entries. At this, I gave up and came here, to find that PHP supported version is 7.4, 8.0, none of which are available in my MAMP.

Now, out of desperation finally, I tried PHP 8.0.1. Alas, all the module changes that the installer had made me to, PHP 8.0.1 was not happy and gave 10+ errors in various modules.

After spending almost 4+ hours on this, I gave up.

Can anyone please guide me on this, to get at least one version working? Comparatively, vTiger install wasn’t at all painfule and was smooth as butter.

It sounds like you got the code from GitHub instead of using the installation packages. Normally you don’t need to do anything to get the composer stuff working, or the CSS compiled, it’s all there in the package.

I installed 8.x straight from the downloaded package from here. 8.x isn’t even available in the GitHub as per my findings.

For 7.x, yes, I downloaded from GitHub simply because this version has source code available and I have requirements of customizing some pieces.

One other thing: I have the documentRoot like “C:\xyz\abc\…” and same with Directory outside of the usual root htaccess folder. Apache is happy and so are other websites I have setup. But May SuiteCRM doesn’t like it?

Have you tried downloaded package with PHP 8.1? Wondering if that is the cause but doesn’t sound like it

Resolved the PHP 8.1 and above, issue “PHP Fatal error: $GLOBALS can only be modified using the $GLOBALS[$name] = $value syntax in …\install\performSetup.php”, used this to fix the 7.x install.

With ChatGPT’s help, I wrote this in that file:

//$GLOBALS = $varStack[‘GLOBALS’];
foreach($varStack[‘GLOBALS’] as $key => $value) {
    $GLOBALS[$key] = $value;

Install of 7.x went fine after that!