SuiteCRM 7.10.2 Maintenance Patch Now Available

SuiteCRM 7.10.2 is now available to download.

This is a minor release of SuiteCRM featuring a variety of bugfixes.

For a full list please View Release Notes for 7.10.2

Thank you to all community members who logged bugs and contributed to this release.

All input is welcome.

The SuiteCRM Team.

2 Likes

Hi, nice update but in portugese pt_PT language the Add User menu is still missing. Its a unknown issue or you guys are working on it?
The best regards Gonçalo Marques

EDIT: its all fine. Thanks, greate work keep rolling guys!

EDIT: its all fine. Thanks, great work keep rolling guys!

I tried a clean install of 7.10.2 with demo data on mac os Apache/2.4.28 (Unix) PHP/5.6.33.
No luck. Worked fine with 7.10.0 (also took some time, but worked in the end).

I upped my php.ini max_execution_time setting to 600 (10 minutes). Still after 10 min I get php error:

Fatal error: Maximum execution time of 600 seconds exceeded in /Users/johnezs/Sites/SuiteCRM-7.10.2/install/performSetup.php on line 62

Time Memory Function Location

1 0.0051 429520 {main}( ) …/install.php:0
2 0.4195 16205312 require( ‘/Users/johnezs/Sites/SuiteCRM-7.10.2/install/performSetup.php’ ) …/install.php:796
3 0.4198 16205480 set_time_limit ( ) …/performSetup.php:62

I tried without demo data. No luck. Same timeout error.

In the apache access log I’m getting one of these lines per second, nothing else:

::1 - - [20/Mar/2018:19:06:08 +0100] "GET /~johnezs/SuiteCRM-7.10.2/install/status.json?0.5127791464043086 HTTP/1.1" 200 29
::1 - - [20/Mar/2018:19:06:09 +0100] "GET /~johnezs/SuiteCRM-7.10.2/install/status.json?0.19572752274409178 HTTP/1.1" 200 29
::1 - - [20/Mar/2018:19:06:10 +0100] "GET /~johnezs/SuiteCRM-7.10.2/install/status.json?0.7138528805182212 HTTP/1.1" 200 29
::1 - - [20/Mar/2018:19:06:12 +0100] "GET /~johnezs/SuiteCRM-7.10.2/install/status.json?0.30217332344005965 HTTP/1.1" 200 29
::1 - - [20/Mar/2018:19:06:13 +0100] "GET /~johnezs/SuiteCRM-7.10.2/install/status.json?0.9848913359587914 HTTP/1.1" 200 29

What do you see in your install.log?

2018-03-20 18:16:15...installerHook: Could not find custom/install/install_hooks.php
2018-03-20 18:16:16...installerHook: Could not find custom/install/install_hooks.php
2018-03-20 18:20:49...installerHook: Could not find custom/install/install_hooks.php
2018-03-20 18:20:58...installerHook: Could not find custom/install/install_hooks.php
2018-03-20 18:21:01...Begin System Check Process *************
2018-03-20 18:21:01...XML Parsing Support Found
2018-03-20 18:21:01...MBString Support Found
2018-03-20 18:21:01...ZIP Support Found
2018-03-20 18:21:01.../custom directory and subdirectory check passed
2018-03-20 18:21:01...cache directory and subdirectory check passed
2018-03-20 18:21:01.../module  directory and subdirectory check passed
2018-03-20 18:21:01.../upload directory check passed
2018-03-20 18:21:01.../zip check passed
2018-03-20 18:21:01...PCRE version check passed
2018-03-20 18:21:01...installerHook: Could not find custom/install/install_hooks.php
2018-03-20 18:21:01...php.ini location found. /usr/local/php5/lib/php.ini
2018-03-20 18:21:01...Outputting HTML for System check
2018-03-20 18:21:01...No Errors were found *************
2018-03-20 18:21:01...installerHook: Could not find custom/install/install_hooks.php
2018-03-20 18:21:04...installerHook: Could not find custom/install/install_hooks.php
2018-03-20 18:21:55...Begin DB Check Process *************
2018-03-20 18:21:55...testing with mysql:mysqli
2018-03-20 18:21:55...Basic form info is valid, continuing Process.
2018-03-20 18:21:55...Testing user account...
2018-03-20 18:21:55...Connection made using  host: localhost, usr: root
2018-03-20 18:21:55...SUCCESS:: no errors detected!
2018-03-20 18:21:55...End DB Check Process *************
2018-03-20 18:21:56...installerHook: Could not find custom/install/install_hooks.php 

Hello,

I just upgraded from 7.10 to 7.10.2 and already regret doing it. Looks like some theme spacing changed and it just became awful! Notification icon and profile icon are positioned weirdly, not straight anymore. Other spaces became bad as well. Some theme colors have changed also. Who keeps changing the theme?

Could this be because the upgrade didn’t go well? Although I didn’t have any issues during the upgrade.

Please help!

Looks like my installation problem was probably caused by php.ini setting display_errors = On. I turned it off (and updated the php version at the same time, so not 100% sure which was the problem, but I’m pretty sure it was the display_errors setting). Now the installation procedure went through quickly.

However, when I log in the left navigation (actions) is empty.
And I keep getting logged out, e.g. if I go to Admin>Repair (“because your session has expired”)

Also, there is no suitecrm.log file in the main directory of the new installation.

So something still didn’t work right.

Not sure but try to clear browser history before going for other stuff.
That helped me several times after upgrades.

I deleted cache and that may have helped?

It seems that having multiple SuiteCRM versions running on the same vhost causes some problems with session management (I’ve had this happen years ago with SugarCRM as well, but not for a while with various SuiteCRM versions). Despite them using different unique_keys.

navigation and missing suitecrm.log may have been false alarms…

I’m with acoolov.
Update from 7.10.0 to 7.10.2 caused a lot of misalignment.

EDIT: For some reason I can’t include an attachment (screen shot) to this… Add file is not working in Chrome.

You can add screenshots with this “guide”

https://suitecrm.com/suitecrm/forum/suitecrm-7-0-discussion/16012-file-attachments-having-problems-attaching-files-to-posts-on-this-forum-solution

I would like to see if the mis-alignments which you refer (and I don’t see in my system) look like broken or missing CSS, or whether it’s something different.

Of course a Quick Repair and Rebuild is advised, and clearing browser caches.

But the miss alignment is even in your demo site as well.

There is a difference in the Profile icon because now it includes the name underneath. So I guess it’s on purpose, though I agree it’s not looking very poilished and probably needs improvement.

If you have any other issues the screenshots will be a nice way to show them to us. Thanks

I think the demo site looks fine.
Rebuild and repair doesn’t fix it.

On our site - even the admin page is ‘off’.

and I still can’t figure out how to attach a file - I’m clicking in the box…

Ok, image attachments are a pain in the ##S on these forums. Maybe you’re better off putting the images here:

https://pasteboard.co

and providing us the link.

You can try deleting your directory “cache/themes”, it will get recreated, and it might solve display problems.

https://pasteboard.co/HcXYDod.png

Deleting cache/themes did not fix it.

Also: https://pasteboard.co/HcY04i2.png

It looks like your new icons haven’t loaded yet, for some reason.

On my system that screen looks ok (I do see one case of a misplaced down-arrow, but nothing more. My sidebar looks fine).

Please try a different browser, and then a different computer, to check whether the problem is local or on the server. Thanks

1 Like

Dusk 7.10 - Much cleaner look. Why did somebody have to change it??

https://pasteboard.co/HcY0klk.jpg

Dusk 7.10.2 - A lot of miss alignment and over all colors don’t look professional and clean anymore.

https://pasteboard.co/HcY16nw.jpg

Also admin page icons were off.