Suite CRM crashed after log files fulled disk

Dear Users!

Today the log files fulled my /var folder and suite crm stopped working.
After enlarge the disk i get an error on the web page:

Could not connect to the database. Please refer to suitecrm.log for details (0).

In the logs:
Sat Mar 14 18:29:02 2020 [846][-none-][FATAL] Could not connect to DB server localhost as suite. port : No such file or directory

I tried a few things, nothing helped, after moved out the /var/lib/mysql/tc.log , now its a totaly crap i even get the darabase error.

Someone could help me ?

Thanks for the help!


A plus info, i dont know why but my deamon.log now fulled the disk again, and the syslog is geting again 5gb now…Dont know what could happen.

You can use logrotate to keep your log files trimmed, and zipped. You can use this for any log, generated by any program.

You should also try to figure out the most repeated useless messages and work to solve them. If your logs are getting spammed so violently, there’s surely a process occupying the server more than it should, it is likely causing a performance problem also.

Okey but the problem if i delete this 2 log big log files i get the database error.
And i dont know why. Now i downloaiding them to see what files it, because this wasnt problem in the last one year when we used it.
Is there are any working solution to rebuild the mongodb?

Sometimes the server need the file to be present. Instead of just deleting them, try reducing their size.

Or you can delete, but then create a new blank file (and make sure it’s ownership and permissions allow the relevant daemon to write to it!)

Will try but i didnt think that will help on the the mysql cant start.

Now i have got it work.I deleted the big databases, make a restart.
Mysql still not worked, and in the mysql log it say cant init tc.log.
So i deleted the /var/lib/mysql/tc.log and started mysql service now its working.

1 Like