successful upgrades but...

I’ve been using SuiteCRM since the beginning (install info listed in signature) and have been upgrading along the way without errors (on screen or in php/suitecrm logs) but I usually have “issues” after each upgrade. I just upgraded from 7.2 to 7.7 using the appropriate upgrade packages (7.2->7.3, 7.3->7.4, 7.4->7.6, 7.6->7.7) and testing the new features after each upgrade. I always notice certain things not working or displaying like a clean install of that version would.

For example, the “Favorites” functionality in 7.4 allowed me to favorite a record (I can see it in the database) but searching with the “My favorites” field checked on would not work and still doesn’t work after the 7.7 upgrade. It works on a clean install of 7.7. Another example is the SuiteP theme in 7.7. I had some weird layout issues that were not present in a clean install of 7.7.

I’d like to point out that I do have customizations in the custom folder but I’m knowledgeable enough to know if they should affect the issues I’m encountering. Like the 2 examples above, I’ve done nothing that would break the favorites search or the SuiteP theme issues. Before anyone mentions it, permissions and repair & rebuilds are always verified and performed.

Those are just a couple of examples (there are others) but what I’m trying to get at is how would someone go about to make sure the upgrade really worked (if they have issues). Maybe certain files were missing in an upgrade package or didn’t copy properly (not reported on screen or in the logs for some reason…)? Or a file that should have been removed wasn’t…and so on and so forth. What would be the easiest/best way to verify this? I’m debating whether it’s just like any other software, sometimes it’s better to start off fresh after many upgrades to make sure everything is working the way it should. Unfortunately that would be very time consuming.

Having said that, thanks for the great product and look forward to using it for many years to come.


Is this still happening in 7.7.1?

Yes it still does. The “Favorites” for example, I had to manually copy the “favorites_only” field to the file custom/modules/Accounts/metadata/SearchFields.php because studio refused to do so for some reason (other fields worked fine).

I also have a dashboard issue that I cannot figure out. It throws a console error on load:

VM269676:6 Uncaught SyntaxError: Unexpected identifier

and it points to this generated script that I cannot find in the file system:

var autoRefreshProcId8944e38b908feb6be07f57ac8ed7ccfa = ‘’;
if (document.getElementById(“8944e38b-908f-eb6b-e07f-57ac8ed7ccfa_interval”).value > 0) { <- this is apparently the Unexpected identifier***
autoRefreshProcId8944e38b908feb6be07f57ac8ed7ccfa = setInterval(‘refreshDashlet8944e38b908feb6be07f57ac8ed7ccfa()’, “0”);
function refreshDashlet8944e38b908feb6be07f57ac8ed7ccfa()


This does not happen if I remove all the dashlets. I have done no dashlet customizations. In addition, the “Add Dashlet” window just hangs with the loading image and it does not throw any log or console errors.

It’s things like these that have me “worried” going forward. If I do a quick comparison of the root folders, my upgraded instance has “examples”, “log4php”, “mobile” & “public” that are not present in a clean install. I know those have nothing to do with the couple of examples listed above, but I probably have some file somewhere causing those issues.

This is my dilemma, I have many field and layout customizations and would like to avoid having to start over from a clean install but I almost get the feeling I have no choice.

Thanks for taking the time to reply.


I am facing a similar issue, my suiteCRM was successfully updated from 7.6.4 to 7.7.7 with showing no errors.
But for some reason after the upgrade, my custom search fields just don’t seem to respond anymore.

I have a custom search field called Center, but if i select any option inside it, it just returns a blank and the leads or contacts with that center are not shown at all.
I Double checked and the leads/contacts did have the center in them.

Kindly help as to what i should do.

Darky, I think that specific bug may have been fixed in the v7.7.8 release. There was an issue with select fields not working in the searches.


Thanks, it was solved in 7.7.8 and works fine now.