Stuck on Confirm Layouts

Trying to upgrade my SuiteCRM to 7.8.5 from 7.8.3. The problem is that I’m stuck at “Confirm Layouts” when pressing “Upgrade Wizard”. After I press “next” and says it was “The following layouts were merged successfully:”. Then I press “Upgrade Wizard” once again and the whole process has to be repeated. I can’t seem to get past the “Confirm Layouts”.


you might need to check your permissions. Also, try a Quick Repair and Rebuild (if you haven’t tried it already).

Finally, you should have some clues in your logs, including in upgradeWizard.log.

1 Like

What kind of permission does the different files require?
I have already tried the quick repair and rebuild, does nothing.

From the installation instructions:

    The system user that your web server uses varies depending on your operating system. Common web server users are as follows:
        apache (Linux/Apache)
        nobody (Linux/Apache)
        IUSR_computerName (Windows/IIS) 

If you are unsure how to set your web server user on your operating system, contact your web server host. 

    Set the following permissions on the SuiteCRM directory(Linux):

        sudo chown -R www-data:www-data .
        sudo chmod -R 755 .
        sudo chmod -R 775 cache custom modules themes data upload config_override.php 

First of all you need to know what user your web server is running under, so you can give the appropriate chown command.

That did the trick. Thank you very much. :slight_smile:
Some of the permissions must have been altered or something.

Glad it’s working now!

But you should make sure your permissions don’t degrade again. Despite several hundred forum threads claiming that it’s “normal”, happens all the time with SuiteCRM, etc., I can assure you it’s just a matter of getting your configurations right, and it shouldn’t happen ever again.

So check these two things:

  • are your cron jobs running as a different user? They souldn’t. Especially if it’s “root”. See this.

  • do you have the correct configurations in config.php? Make it like this:

'default_permissions' =>
array (
'dir_mode' => 02775
'file_mode' => 0755
'user' => '<youruser>', // you must replace <youruser> with the actual value
'group' => 'yourgroup', // you must replace <yourgroup> with the actual value

What value does and has to be?
In my config, they’re just empty.

Whatever your web server user is, I don’t know. You didn’t even tell me what OS you’re running…

If you used user “www-data” and group “www-data” in the commands above, and it worked well, then that should be it.