Step 2 of 2 - Configuration

Hi,

I fill in all of the required fields on this screen but the “Next” button doesn’t do anything. Is there an error log that I can check?

Thank you,
Chris

Yes, you can check install.log on your SuiteCRM root, and your web server log which might be called php_errors…log or similar.

You might also want to share with use some details about your system, versions of :

  • SuiteCRM
  • PHP
  • OS
  • database
  • web server

I found the Install.log file…I’m getting the following error:
installerHook: Info: custom/install/install_hooks.php not present, no custom hooks to execute

Side note: I’ve discovered that the SuiteCRM install does not work with the latest PHP 7.2.5…it only works with PHP 7.0.30. When you try to install on the latest PHP, you get a Session.save_path error…so painful!!!

I’m trying to install SuiteCRM 7.10.5

DB = MySql

I’m on SiteGround infrastructure

I’ve tried installing SuiteCRM on two different instances.

Please help.

Thanks,
Chris

That “error” is not an error, it’s just an information (“info”).

You can use 7.10.6, by the way, it’s out now.

You should be able to use PHP 7.2, if you have an error, it needs to be worked out. Often there are things specific to individual shared hostings.

Anyway, we need some clue about what Siteground doesn’t like about SuiteCRM (or vice-versa). Can you get the web server log?

I would also try enabling PHP modules (try doing it from CPanel, if you can’t, try from php.ini).

These are the modules I install for Ubuntu with PHP 7.0, you won’t be able to use that command, but you can look for similar names in CPanel:

apt install zip unzip php-mbstring php7.0-mbstring php-gettext php-xml-parser php7.0-zip php7.0-imap php7.0-gd php7.0-curl phpmyadmin

SuiteCRM 7.10.6 works w/ PHP 7.2…so that’s good!

Here is a link to show what’s my php.ini file look likes. http://open-roche.com/phpinfo.php

Again, the “Next” button does nothing on Step 2 of 2 page…can I manually execute whatever the next step is?

Error from webserver log file:
[Fri Jun 08 09:45:22.750512 2018] [core:crit] [pid 12977] (13)Permission denied: [client 24.218.255.195:58546] AH00529: /home/chrisa44/public_html/cache/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that ‘/home/chrisa44/public_html/cache/’ is executable, referer: http://open-roche.com/install.php

I’ve removed the .htaccess file…also changed permissions to 777…and at least the Next button works now.

But…now it can’t connect to the DB… I’m connected to the DB via MySQL Workbench…w/ the same credentials that I’m filling in the form on Step 2 of 2 on…any suggestions?

Please fix the following errors before proceeding:

The provided database host, username, and/or password is invalid, and a connection to the database could not be established. Please enter a valid host, username and password

What are you using for “host” on SuiteCRM installation Wizard? Normally it would be just “localhost”, without any port number (assuming it’s default port).