Some schedulers run fine and others dont...???

The following schedulers have never run, and I’m not sure why. I noticed my AOD index isn’t building, as AOD search doesn’t work, so I guess it’s related to this:

Run Scheduled Reports last run never
Optimise AOD Index last run never
Perform Lucene Index last run never

The job logs on the schedulers page does say queued and then done, but it doesn’t actually seem to work.

The following reports are working fine:

AOP Check Inbound Mailboxes runs fine
Run AOW WorkFlow runs fine
Check Inbound Mailboxes runs fine
Run Nightly Process Bounced Campaign Emails runs fine
Run Nightly Mass Email Campaigns runs fine
Run Email Reminder Notifications runs fine
Clean Jobs Queue runs fine

Cron is working. This is the format I am using (1&1 shared server):

I had to modify the cron.php script to remove a couple lines of code:

Removed line 47-50 of cron.php

$sapi_type = php_sapi_name();
if (substr($sapi_type, 0, 3) != ‘cli’) {
sugar_die(“cron.php is CLI only.”);

Since the AOD scheduler isn’t running, that is probably why modules/AOD_Index/Index/Index/ only has read.lock.file. Any idea what I can do to get the scheduler to run for those and get the index building?

I’ve reset the schedulers and re-added them, did a repair and rebuild but no help.

This is my cron.php, which I’m assuming is pretty generic:

<?php if(!defined('sugarEntry'))define('sugarEntry', true); /********************************************************************************* * SugarCRM Community Edition is a customer relationship management program developed by * SugarCRM, Inc. Copyright (C) 2004-2013 SugarCRM Inc. * SuiteCRM is an extension to SugarCRM Community Edition developed by Salesagility Ltd. * Copyright (C) 2011 - 2014 Salesagility Ltd. * * This program is free software; you can redistribute it and/or modify it under * the terms of the GNU Affero General Public License version 3 as published by the * Free Software Foundation with the addition of the following permission added * to Section 15 as permitted in Section 7(a): FOR ANY PART OF THE COVERED WORK * IN WHICH THE COPYRIGHT IS OWNED BY SUGARCRM, SUGARCRM DISCLAIMS THE WARRANTY * OF NON INFRINGEMENT OF THIRD PARTY RIGHTS. * * This program is distributed in the hope that it will be useful, but WITHOUT * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS * FOR A PARTICULAR PURPOSE. See the GNU Affero General Public License for more * details. * * You should have received a copy of the GNU Affero General Public License along with * this program; if not, see or write to the Free * Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA * 02110-1301 USA. * * You can contact SugarCRM, Inc. headquarters at 10050 North Wolfe Road, * SW2-130, Cupertino, CA 95014, USA. or at email address * * The interactive user interfaces in modified source and object code versions * of this program must display Appropriate Legal Notices, as required under * Section 5 of the GNU Affero General Public License version 3. * * In accordance with Section 7(b) of the GNU Affero General Public License version 3, * these Appropriate Legal Notices must retain the display of the "Powered by * SugarCRM" logo and "Supercharged by SuiteCRM" logo. If the display of the logos is not * reasonably feasible for technical reasons, the Appropriate Legal Notices must * display the words "Powered by SugarCRM" and "Supercharged by SuiteCRM". ********************************************************************************/ //change directories to where this file is located. //this is to make sure it can find dce_config.php chdir(dirname(__FILE__)); require_once('include/entryPoint.php'); if(empty($current_language)) { $current_language = $sugar_config['default_language']; } $app_list_strings = return_app_list_strings_language($current_language); $app_strings = return_application_language($current_language); global $current_user; $current_user = new User(); $current_user->getSystemUser(); $GLOBALS['log']->debug('--------------------------------------------> at cron.php <--------------------------------------------'); $cron_driver = !empty($sugar_config['cron_class'])?$sugar_config['cron_class']:'SugarCronJobs'; $GLOBALS['log']->debug("Using $cron_driver as CRON driver"); if(file_exists("custom/include/SugarQueue/$cron_driver.php")) { require_once "custom/include/SugarQueue/$cron_driver.php"; } else { require_once "include/SugarQueue/$cron_driver.php"; } $jobq = new $cron_driver(); $jobq->runCycle(); $exit_on_cleanup = true; sugar_cleanup(false); // some jobs have annoying habit of calling sugar_cleanup(), and it can be called only once // but job results can be written to DB after job is finished, so we have to disconnect here again // just in case we couldn't call cleanup if(class_exists('DBManagerFactory')) { $db = DBManagerFactory::getInstance(); $db->disconnect(); } // If we have a session left over, destroy it if(session_id()) { session_destroy(); } if($exit_on_cleanup) exit($jobq->runOk()?0:1);

My log shows:

Wed Mar 25 13:27:01 2015 [3729][1][FATAL] Job 6de4f6b8-7958-f422-942c-5512ef3e6897 (Run Scheduled Reports) failed in CRON run

Wed Mar 25 13:27:02 2015 [3729][1][FATAL] Job 6ad10213-b9ae-925f-d31e-5512ef821005 (Perform Lucene Index) failed in CRON run

Wed Mar 25 13:28:02 2015 [4505][1][FATAL] Job c1726922-e230-7c47-9bfc-5512ef61a749 (Optimise AOD Index) failed in CRON run

Running 7.2.1

Does anyone know if it has something to do with scheduledtasks.ext.php @ /custom/modules/Schedulers/Ext/ScheduledTasks/

If I disable AOD, both Optimise AOD Index and Perform Lucene Index run…

Run Scheduled Reports still doesn’t run, but any idea why unchecking AOD allows the above to run?

read.lock.file is still the only file in /modules/AOD_Index/Index/Index/ however.

If you disable all the AOD (AOD, both Optimise AOD Index and Perform Lucene Index )

Does the Scheduled Reports run ?

It can some times be if one of the scehduled tasks has a problem others might not run. might be worth checking permissions on the instance and the apache/php log to see if that points to any errors.


I’m running 775 on the system, and cache is 777, so I don’t think it’s permissions.

I’m not quite sure how to access the apache logs since my system is hosted on a 1&1 shared server.

How do I disable all of the AOD? Under AOD settings, it’s just a single check box to enable AOD.

Even though the scheduled task is running for AOD Index and Lucene Index, I’m assuming it’s not really doing anything since my index isn’t building?

Yep. you would also have to turn off the scheduler jobs.

You may beable to get access via the 1and1 control panel, however I am unsure.

I recon that if your permissions are like that and its still not working then you need to access the error logs to see if there is anything in there.

Would my config.php permission settings matter?

I’m running the following:

array (
‘dir_mode’ => 1517,
‘file_mode’ => 436,
‘user’ => ‘’,
‘group’ => ‘’,

we recommend setting dir_mode = 1517 and file_mode = 420

user which will depend how the servers been set up so could be www-data, apache etc

same goes for the group set it to the group for the webserver. again could be www-data, apache.

They might be behind it then again it might not, it would be hard to tell without a error to point in tht right direction.


I called 1and1 and they said on a shared server, there is no access to apache/php logs… :frowning:

I’m going to check the logs the server does allow (ftp/access, etc) to see if it helps but I’m not sure.

please guide me to get solution in windows for same problem