Screen Greyed out on save, Cannot click close button

Screen is greyed out on clicking the save button in Admin ONLY when a pop up is involved. Other save buttons in main CRM work fine.

When editing modules in Studio, or creating new modules, the screen greys out and the pop up with say “This operation completed successfully” and then I have to press F5 to continue working. The pop up close button doesn’t click as the grey sections seems to be sitting over the top of it.


SuiteCRM v 7.9.9
PHP v7.0

Same problem here. Noticed it in module builder. When I save something, it hangs on a greyed out ‘this operation is completed successfully’. It goes away if you click one of the menus at the top of the page and the change is committed, but obviously this makes building a module very difficult as you have to navigate back into module builder after every change.

Tried on Firefox 57.0.4 (on ubuntu) and Chromium (ubuntu also).

Server is running ubuntu 16.04 server with php 7.

Did you get anywhere?

Sorry to double post but cannot see an edit button.

To rule out some odd mismatch of php/apache/mysql versions also tried and the same results using 7.9.9 on Fedora 26 server.

Also tried on windows client with chrome and firefox. Module builder broken for me. Any help appreciated.

I have the same problem. Pressing F5 is OK but sometimes this is not the solution. For example, if I want to change a label of a subpanel of a module when pressing F5 it does not save the action. Currently I have panels that names need to be changed but I am unable to do so. There are other issues like deleting relationships etc…that do not work because of this.

If you have this error in your logs when this happens,

Fatal error: Uncaught Error:Cannot access private property UndeployedMetaDataImplementation::$_packageName

then the fix you need might be this one:

Debian, MySQL, PHP7.0, Suitecrm 7.9.9
Same problem here.
I don’t see that error on the logs


The greyed out, unclickable floating div seems to be a result of a low z-index.

In chrome, F12 for developer tools, select the div in Elements and enter a higher z-index (100) in the Styles tab, and the popup comes to the foreground and is clickable.

How would we resolve this permanently though ?

@imni the developers have worked on several fixes for this kind of issue recently. So if you find new ones that aren’t fixed in the latest versiions, please report them on GitHub and they will be fixed promptly. Thanks

@pgr Thanks.

I am currently using an installation recently upgraded to v 7.9.9.

Re. github postings… This was the link that stood out when searching this issue. Is there a better way to search issues ?

It’s ok to start the conversation here on the Forums, since that helps rule out any issues specific to your installation.

When you’re pretty sure it’s a bug in the code (and these z-index issues are) you can report here:

You can search that list before reporting, to check if it’s already reported.

For these issues you need to check on the very latest version, there were many fixes after 7.9.9. You can use the online demos to double-check:


Great, thanks.

Hi everyone.

I have fixed this issue.

The change is below:

I have changed mask{z-index:3 !important} into mask{z-index:0 !important} at LINE No. 70 in “/cache/themes/SuiteP/css/style.css”

Hard Refresh after adding, then you will see the change.

If you need help doing this, you’re welcome to contact us.

@adzychester thanks for the tip.

I do hope this is fixed in the latest versions, please everybody tell me if it isn’t.

Another detail is that applying any fix in the cache directory won’t survive a Quick Repair and Rebuild, or even some other minor cache management events. It’s also not upgrade-safe. But it can serve as a temporary workaround.

Seriously. Is this fixed in the update yet?

It’s impossible to add new modules or edit anything in the modules, as you can’t save them without this being fixed. This is a critical issue, an absolute showstopper.

It’s impossible to add panels, and change panels as you can’t save the name.

This needs to be fixed immediately. Without it, I’m moving to another CRM as our supported CRM, as we can’t modify it at all.

I upgrade to 7.10 and don’t have that problem anymore. It’s gone!

1 Like