"safety" settings in 7.2.2?


I have just updated from 7.1.5 to 7.2.2 and find that I cannot do some stuff that I used to do before.

As I am still learning how to use suitecrm, I find that I create several quotes or invoices before they are ready to issue. As my skills grow and I gain experience I expect that I will not create so many useless documents.

In version 7.1.5 I could delete unnecessary quotes, etc. In version 7.2.2 the delete button seems to do nothing.

I am aware that it probably not good practice to go around deleting quotes, etc. But I really need to at this stage.

Which settings in Admin do I need to change to allow me to delete?



The problem has vanished now that I am using a different browser.

I was using Chrome for the upgrade, and had a couple of minor problems (including missing navigation panel).

Now I am using another pc with Firefox, and the problems have gone.

People answered my other postings, suggesting a caching issue. I think that was the problem.

Please consider this mystery solved. For now.