Report - exporting to CSV produces broken output when currency fields included

If you create a report that includes currency fields where a comma ‘,’ is used as a thousand separator then the system doesn’t strip this out when generating the csv output. The result is that the relevant lines come out with extra fields and needs to be fixed when pulled into excel.

Currency fields should be ‘sanitised’ before export into csv.

Hi there,

This is a bug in AOR. To workaround until a fix is implemented, you can change your delimiter in your user settings.



There is a fix for this in git hub:

[PATCH] Bad CSV export on Reports module #18