Relate field in subpanel doesn't display data


I’m working on an ambitious SuiteCRM customization for my company. We aren’t using any built-in modules except Users. I’m having trouble with a relate field not displaying in a subpanel. Here’s the layout:

Module A is a field in Module B (one-to-many relationship).

Module B is a subpanel in Module C (one-to-many relationship).

In the Module C subpanel, the Module A field appears in the header and layout, but it’s always blank. If I click on Edit, there’s data in that field. This problem appears in subpanels for other modules, too, but only for the Module A field (i.e., when there’s a Module D field in Module B, it shows up fine). So it seems to be something wrong with Module A.

I have tried many QRRs, and at one point I deleted Module A entirely and rebuilt it from scratch, but the problem keeps happening.

Any suggestions? Thanks!

Have you tried doing a quick repair and rebuild from the admin pane?. Also do a rebuild relationships.

Yeah, I’ve tried both. No change.

File permissions perhaps? If permissions are not correct the repair and rebuild wont always take effect.

Is developer mode turned on?

Grasping at straws here I know but often problems like this are caused by caching issues.

Developer mode is off. I tried turning it on and doing a quick repair and rebuild and rebuilding the relationships, then turned it back off. Nothing changed.

The permissions seem to be working properly. I had some trouble getting everything working after I installed, so most of them are set to 777 for the time being.

Id leave developer mode on while your making customisations, it just means that changes will take effect right away.

As for your problem I’m not sure, have you created proper custom relationships via studio between the modules or are they relate fields? I don’t think the problem will be with Module A.

They’re all custom relationships, not just relate fields.

An addendum: this problem is also happening in the list views for Modules B and C, not just the subpanels. So the Name field from Module A is not displaying in related modules in anything other than Detail and Edit views.

Thanks a bunch for your help on this, by the way.