Redis connection failure

I am running locally on a mac with MacOS El Capitan. I have version 7 of php installed and the latest version of MySQL. I have installed the current version of suiteCRM and it seems to work except that it keeps spewing errors about something called Redis:

( ! ) Warning: Redis::connect(): connect() failed: Connection refused in /Users/Admin/Sites/SuiteCRM/include/SugarCache/SugarCacheRedis.php on line 102
Call Stack

Time Memory Function Location

1 0.0002 371112 {main}( ) …/index.php:0
2 0.0007 397616 require_once( ‘/Users/Admin/Sites/SuiteCRM/include/entryPoint.php’ ) …/index.php:47
3 0.0828 9787536 SugarApplication::preLoadLanguages( ) …/entryPoint.php:170
4 0.0828 9787536 return_application_language( ) …/SugarApplication.php:357
5 0.0828 9787608 sugar_cache_retrieve( ) …/utils.php:1033
6 0.0828 9787608 SugarCache::instance( ) …/SugarCache.php:166
7 0.0828 9787608 SugarCache::_init( ) …/SugarCache.php:98
8 0.0843 9873872 SugarCacheRedis->useBackend( ) …/SugarCache.php:79
9 0.0843 9873872 SugarCacheRedis->_getRedisObject( ) …/SugarCacheRedis.php:78
10 0.0844 9873912 connect ( )

I see that Redis is some open source caching software…Every page load produces these connection errors.

Can anyone shed any light on this?


This is the first time I’ve heard of the existence of Redis, but from a quick Google search I would say you have to ways to do this:

  • remove redis module from your computer, if it is not needed

  • configure config_override.php to use Redis caching. I don’t know details, you’ll have to look it up on Google…

Good luck, please share your results here if you solve the problem.

1 Like

No idea how to remove it and it seems like a pretty integral part of suiteCMS. Surprised no one has seen this issue.

No, you remove it from your Mac’s PHP, it’s a module. Then SuiteCRM won’t try to work with it. It’s not really needed.

1 Like

OK I ran phpinfo and found this in the dump:


Opened that and commented the `1 line out there and that got rid of the error. Thanks so much!

The warning you are receiving means that your system doesn’t have redis installed.
Unfortunately I have no idea about MacOS, so better google it how to install it.
I just installed and run it on Centos 7 check here
No special configuration needed.

Hey there,

I know this topic is quite old already. Nevertheless for me the problem seems to persist. Once in a while, I receive a message “Redis::connect(): connect() failed: Connection timed out in /var/www/vhosts/ on line 102”.

Redis is running on my host on the standard port, PHP extension is enabled.

Where is the documentation on Redis caching configuration ?

Best regards,

Did you restart the apache?