Problems with API V8 and apache2

Hi all again.

I asked for help a few days ago about the Api and i make it work in my local enviroment thanks to your help. Now, i’m facing another issue. In the client server, the havey apache, and i can’t make the API work. I created the private and public key in the Api/Oauth2 directory, i added the Oauth2_encryption_token, i changed the option in /etc/apache2/apache2.conf to be Allowoverride All, i rebuilded the .htcacces from the Suite administrator page, but i cant get a token, i always get a 404 not found.
We are using apahce 2.4, and Debian 10 (buster) as an OS. Do you have any idea what could it be? or maybe i’m forgetting something to set up the Api?

Thanks in advance!


Are you still having issues with this?

If you navigate to the url:
{instance URL}/Api

What do you see?

I believe, if the API is working, you should see something similar to this:

If not, then it would be worth re-visiting the setup of the API.

One thing I’ve encountered previously was that the “mod_rewrite” apache module wasn’t enabled:
Can you check if this is enabled on your client server?

Otherwise, could you pass over the URL/Body format that you are using to send the Auth request?
Would be good to get a look at that too :slight_smile:

Hi John, thanks. The problem was that the apache was not configure well (you need to put Allowoverride All), and there were some apache mods that were missing.

1 Like

Ah great,

Glad you figured it out!

1 Like