Possible bug in AOR Reports

I am running SuiteCRM 7.4 full version under Linux.

I have created a report which lists contacts related to accounts under certain conditions.

The Reports lists a few fields and has two parametric conditions:
. the first condition checks the value of a MultiEnum field in the Accounts module
. the second condition checks the value of a DropDown in the Accounts Module
(see image)

When I view the report I get the results for the default values of the conditions. The results are correct: one record matches the conditions.
See image:

From now on, whatever I do the result is no longer correct.
I have tried one or a combination of:
. only press update
. change the value of parameter 1
. change the value of parameter 2
. try both parameters with the original values
The result is always an empty set.
(see image)

Is this a bug or am I doing somethinmg wrong?

I have checked the Apache logs: no errors.
In the suitecrm logs I found an error related to Scheduled reports, so I deactivated the Scheduled Reports Scheduler since I read there is a known bug/issue pending resolution.

Apart from that I did’nt get other errors.

I am pretty sure that permissions are set correctly (775 and 755 + in config.php and include/utils.php, and additionally I have a scheduled task that resets everything to 775/755 every minute).

Does anyone have an idea why this could be happening?

Is it a bug or am I doing something wrong?

Bump

Could anyone from the SuiteCRM team help?

Thnxs!

Hi,

This seems to be a bug with the MultiSelect Field on reports.
I’ve logged it on our Repository as an issue: https://github.com/salesagility/SuiteCRM/issues/645

Thanks for Highlighting this!

1 Like

Hi there,
Seems like I have the same issue.
The proposed solve doesnt solve the reporting with dates.
In my case I select a date and then it changes to a 1 past date.
And the report is not correct.

Please help,
Ive tried to reach support to help me on this. But they say to reach here on the forum.

Hey martintoy,
Would you be able to give us more information on the issue?

I.e, Screenshots of the issue you are having?

We can then check if it is logged on our Github repository, (Or log it if it is a bug in SuiteCRM that hasn’t been logged), and a developer will be able to investigate when available.

Hi John,
Thanks for your answer,

1.- We made some pre-configured reports, so this way the user can select the dates they want.
If you go to the Dashboard then Reports and select a specified report. One should be able to see the report, modify the dates and retrieve your report.
However the dates are blank and the report is from all the registries. See there are 2813 registers which is not correct.

2.- If you edit the report we can see the whole report with its parameters, one can modify the dates of the report in Conditions, then save. And after that the report appears correctly.

3.- The result from 30/11 to 30/12 is correct. Below the screenshot. However the dates are moved to a day before.

Thanks indeed for your help

Hey Guys,
Any update on this?
Please advice,

Martin

Hi Martin,
this is a known issue and there are some fixes proposed:

https://github.com/salesagility/SuiteCRM/issues/1082

https://github.com/salesagility/SuiteCRM/issues/1083

https://github.com/salesagility/SuiteCRM/issues/1253

Best Regards