Phantom Relationships

Thanks in advance!
I’m having problems with relationships.
I started creating a new module and relationships to Contracts, when i tried to deploy it, received an error but the tables and relationships where created. I tried to uninstall and delete all custom but some relationship still there.
When i go to Studio>Contract> and make click en relationship, the CRM freeze and it’s necessary refresh the page to continue using the system.

i tried to delete from files but i dont know inwich files i must erase them

There is a way to delete the relationship not from studio?

I tried repair the system, the relationships, delete the tables from SQL but they are re-created.

In this scenario,the main problem is when i enter to “Contracts” the sub panels doesn’t show.

SuiteCRM Version: 7.9.7

Thanks for your help

This could be a bug in your version, 7.9.7 is pretty old.

Any way, you need to discover where the left-over relationship definitions are coming from.

A couple of things you can check:

  • in Admin / Quick Repair and Rebuild, sometimes when you scroll to the bottom, you get a button saying “sync database with vardefs”, this solves some problems. Try this first.

  • in database, there is a table called fields_meta_data that holds information about relationships. There is also a table “relatinships”, but it is automatically generated, don’t change anything there.

Other places to look for traces of definitions:


Do you recommend update the version? Maybe can be solve that way. (Where can i download it?)
I already try using the button in the bottom of the repair and that function recreate the tables, still having in count that relationships.

I’ going to look the files that you tell me.

Thanks a lot for your help. I’m new in SuiteCrm and this it’s giving me terrible headache

I already update to Version 7.9.17 Sugar Version 6.5.25 (Build 344)
And the problem still remains.
I check the files that you mention and delete all references to the relationships but no result

there’s a way to debug the site?

Note that 7.9.17 is not the newer version, it’s actually a branch that is no longer updated. Any reason not to go for 7.10.x?

You probably have many clues waiting for you in the logs:

php_errors.log (or whatever your web server log is called)

The reason why i don’t went to 7.10.X it’s because read somewhere that version doesn’t suport translation package (honest i dont know wich patch of this version)
if you have any information of this please let me know.

I activate the display errors in php.ini and confirm the problem is when try to show a tab of this relationship that doesn’t exist anymore
Also i’m going to check the logs that you tell me.

Thanks you are really helpfull

Of course 7.10 has language packs. I don’t know where you read that?