Personal emails wont show up in dashlet unless assigned to user

I am trying to set up the email dashlet to show personal emails. I found that commenting out line

‘this->filters[‘status’] =array(“unread”)’
in “modules>Emails>Dashlets>MyEmailsDashlet>MyEmailsDashlet.php”

kinda fixed the problem but it doesn’t show the newest email unless the user replied to it. Looking closer, it appears that the personal email does not show up on the email dashlet unless it is assigned to the user.

How can I set it up where incoming emails are automatically assigned to a user so that it shows up in the dashlet?

I have to admit that I am not the sharpest tool in the shed but I hope that my input provides enough information for people to understand whats going on.

Hey there,

Are you still having issues with this?

I believe what you’re seeing is due to how the CRM deals with Emails

When an Email is detected by the CRM, it is visible in the Emails module
But, it may not exist as a full email record yet, until it has been “Imported” into the CRM
This means that it won’t have an Assigned User or a Relation to any record as of yet

I believe, by Replying, the Email also goes through the Import Process (which assigns it to the Replying user)

You can read a little more about this here

Some things worth trying could be:

  • If you edit the filters for the dashlet, and uncheck “My Items”
    Does this show other items?
    I feel you may have the same result if the Email records have not yet been imported

  • Try Creating a Group Mail Inbound Account, (if you have not already)
    The Documentation notes that Group Email Accounts can be configured to Import Emails Automatically
    If this does indeed create Email records for the incoming Emails, you should be able to use a Workflow to assign Emails to a specific User