Permissions Issue When Importing Updates

Error The record could not be updated due to a permissions issue
Field Name ID
Value 4b815815-992d-9766-46c8-5ad41e5081bf

Thanks for any help!

New Records go in just fine. Original Records I’m trying to update have been imported using a custom php script.

Which module is this?

Your error is coming from here:

I believe it mentions “permissions” in the sense of “SuiteCRM security settings permissions”, not in the sense of “Linux permissions”.

So you need to find a way to make that “CloneBean” work - maybe try this with an admin user, and if it works, then check the Roles and Security Groups to make sure your users can also do the updates.

I’m using the admin account. Still no joy :frowning:

Can you give yourself better access to that record? Make sure security Groups and roles aren’t restricting you.

But maybe something else is wrong that is causing the Clonebean to fail. If you can go inside that with a debugger you will find out.

My module wasn’t showing up in the role management snap-in. Did a role repair and it does now. Too tired for imports now. Will try tomorrow and post result.

Thanks pgr… always appreciate the kind help :slight_smile:

I expanded (and trimmed) on the script you shared with me and got it drilled down also. Will post the final after adding comments for others who may need something similar, which appears to be a lot. Something I think would be pretty awesome to add is a real-time popup window that shows the log/debug info as each record goes in with a progress bar. I’m trying to nail that down as well. I assume ajax will be involved.

Hey @AeroDonkey, I’m having the same issue you had.
I’m forcing the ID field of my Contact records to be one I have in my own system, but when I loaded this file (large one, 1200 records) I had a badgateway error and had to delete all the records to reupload them.

When I tried to reupload, I got the error in all records of the file.

Could this be related to the error?

@pgr I also checked my roled and permission groups. I don’t have any set-up and I’m admin as well.

I’m using Suite CRM 7.11.15, with the latest PHP version

Old thread, but if anyone else has this issue, it can happen when you force the SuiteCRM ID and when that ID already exists in the database. This permissions error shows when Suite tries to create a duplicate primary key in the data table. This includes deleted records from a broken import or whatever. In our case we purged deleted records in the database and then this issue was resolved.