PDF Templates (Create) Blank

When I choose PDF Templates from the menu, there are no default templates. I don’t know if there are supposed to be any or not, but there are several listed in {suitecrm]}/modules/AOS_PDF_Templates. In any case, when I click ‘create’ I just get a menu and a blank page. I’ve tried to load this page with Ajax enabled and disabled since I saw in other topics that disabling Ajax on some pages helps in some similar cases.

Any tips would be greatly appreciated.

Hi Kristin,

What browser are you using? Have you set the correct permissions on your instance and/or tried a Quick Repair and Rebuild?



I’ve tried it on a few different browsers and a couple different machines. I get the same results on all of them. I’m not sure what the permissions should be, but it looks like all the directories and files are set to 777, (which seems like it might actually be too much). Do you have particular directories and permissions I should check?

I have repaired and rebuilt and the page is still blank.


check your the php error log or enable and display php errors to see what the issue is?

1 Like

Ah! Yes - I turned on PHP error notification and saw an error about being unable to open @eaDir. That’s an indexing folder Synology uses. I zapped that folder and now the create page comes up!

Are there supposed to be some sample templates available? I see some listed in the /samples folder but they don’t list when I open PDF Templates. I was hoping to be able to modify some samples instead of starting from scratch.


I found what I was looking for. I thought the samples would be listed when I first went to PDF Templates. But instead they are listed in the Create form as a starting point. Perfect! Thanks Will!