Password reset emails trigger admin user password reset, not user selected


Seem to have a problem with the password reset mechanism. Logged in as an Administrator, I select the user I want to issue the reset, and click on the link. What then happens is the Administrator’s password is changed and an email is sent to the administrator email address. I can see the user_hash changing for the Administrator, and nothing happening with the end user’s

In case it helps, I added all my users via an import and did not get the system to create and email out passwords as we were not ready to scare people yet :slight_smile:



It looks like this bug:

There’s already a fix proposed, but it hasn’t been released yet. But if you need to fix your system right away, you can just copy those changes into your system.


Installed the fix, and ran a “quick repair”, and that seems to have solved the issue, so looks like that bug fix is a good one.

Thanks, and will let you know if it has any side effects that I notice.

And like you say, it doesn’t work unless the relevant cache is cleared, in case anyone else is reading this and wondering why it hasn’t worked for them.