Outgoing email issues


I have added individual emails for “users” with their login and password info and sent a test email which works fine.

Then in the admin -email settings, I disabled “Allow users to use this account for outgoing email” so that instead of using system email, users use their own email for “outgoing emails”.

However, when system emails is turned on these users can send their emails, BUT with it turned off, they cant send email and get the error saying that “username and password is missing”, so it seems that the despite keeps trying to use the “default system email” for outgoing email and not the second one that is added in the “outgoing settings” for the user.

Wonder what I might be doing wrong here?


Where are they trying to send emails from?

If in the email module they must do add their information in Email > Settings > Mail Account > ADD(Outgoing SMTP Mail Servers header)

1 Like


The user is trying to send the email from the email module and their email has indeed been added in: Email > Settings > Mail Account > ADD(Outgoing SMTP Mail Servers header)

But despite that when they click on Send, they get the above error as the system keeps trying to use the “system default email” to send.

can you please detail this error? is there anything in the System logs?


What would be the best place to check the logs?

In short the steps to replicate the error are:

  1. Login as admin and uncheck “Allow users to use this account for outgoing email” in Admin-Email Settings
  2. Login as User and add your Outgoing SMPT in - Email > Settings > Mail Account > ADD(Outgoing SMTP Mail Servers header) - So now it will show two emails there - one is the system one and second one being the one added by user (see attachment).
  3. Try sending an email and it gives the error “username and password is missing”.
  4. Log back in using admin account and check “Allow users to use this account for outgoing email” in Admin-Email Settings - and the error is gone.

So what this means is that the email added by the user is not being considered at all, and the email module keeps trying to use the default system email to send outgoing emails.

Missing attachment

You can check the system logs in Admin > System Settings > View Log > All

Another quick thing while I try replicate this, do these users have the emails set up in their Users profiles aswell? Admin > User Management > (user) > Scroll down the information should be filled in(SMTP etc)

Thanks. You nailed it. That was the reason. Wonder why the same user info is required in two places though?

Also, are there are benefits to allowing a system wide email as opposed to “user-wise” email? Is there a benefit to using 1 approach versus the other?

Depends what you want your users to be able to do and send from. The outbound email setting is used system wide e.g. sending stuff out on behalf of the company. Usually like at info or support email. If you allow the ‘Allow users to use this account for’ field this means that they will have the option to send from that email aswell. If you dot select that just means the user will always send from their personal email

1 Like

Interesting enough, when I do “Allow users to use this account”, even though two “outgoing SMTP” servers are shown in the list (system one and their own), but in the “from” dropdown, they can only choose their own email id. So I am assuming, whether we allow them to use their own email id, or if they use system-wide smtp server, the “from” address will always be their own (even if they dont save their own credentials in their user settings)?

If there own Email is set up they will always have the option of both yes.

If they dont set up their own it will default to the system

I have both the server option enabled and users own saved but the dropdown just shows the users email address. Please see the two attachments.