Old themes Add Dashlets not showing [Fixed]

Upon upgrading to 7.7.5, in old themes the add dashlets its not working to fix you must change MySugar.js
located in include/MySugar/javascript/MySugar.js

Method showDashletsDialog
where you see
change to

This fix will work for both old themes and new themes.

1 Like

Thank you for the info however this fix did not work for me. I am still receiving the warning message and can not add a dashlet.

Witch theme are you using so I can make a few tests.


Thank you!

I also tried SuiteP and SuiteT - I am getting the same error and can not add dashlets.

Try updating to 7.7.6 they fixed the issue.

Now I can not access anything! My login screen shows this:

Warning: Declaration of SugarEmailAddress::save($id, $module, $new_addrs = Array, $primary = ‘’, $replyTo = ‘’, $invalid = ‘’, $optOut = ‘’, $in_workflow = false) should be compatible with SugarBean::save($check_notify = false) in /home/xxx/public_html/xxxx/include/SugarEmailAddress/SugarEmailAddress.php on line 1162

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/starnet/public_html/snscats/include/SugarEmailAddress/SugarEmailAddress.php:1162) in /home/xxxx/public_html/xxxx//include/MVC/SugarApplication.php on line 619

Warning: Cannot modify header information - headers already sent by (output started at /home/starnet/public_html/snscats/include/SugarEmailAddress/SugarEmailAddress.php:1162) in /home/xxxx/public_html/xxxx/include/utils.php on line 2802

Warning: session_regenerate_id(): Cannot regenerate session id - headers already sent in /home/xxxx/public_html/xxxx/modules/Users/Authenticate.php on line 49

Warning: Cannot modify header information - headers already sent by (output started at /home/xxxx/public_html/xxxx/include/SugarEmailAddress/SugarEmailAddress.php:1162) in /home/starnet/public_html/snscats/modules/Users/Authenticate.php on line 115

oh yeah…and I still can not add dashlets. :frowning:

The erros that you are reporting, looks like some configuration issues.
see the following threads

You must in your php.ini display_errors set it off there are some issues with that
also give permissions to your data

What I do is set:

chmod 755 $(find [color=#ff0000]yourCRMfolderhere[/color] -type d)
chmod 644 $(find [color=#ff0000]yourCRMfolderhere[/color] -type f)

this will give 755 to the directories and 644 to the files

chown -R apache:apache [color=#ff0000]yourCRMfolderhere[/color] – if you are using apache as a web user

1 Like

:cheer: :cheer: :cheer:

Thank you! That worked! it’s always the dang php.ini file! :stuck_out_tongue:

SuiteCRM you rock! :kiss: