now what, all module pages blank

Can anyone actually use this crm in real life? I’ve been setting it up for a month, and so far it is a never ending job trying to figure out all the bugs. 5 hours of dealing with bugs for every hour of adding content.

The latest is it was close to working, but now all of a sudden the pages / modules are blank. The menu shows, but clicking on any of the menu links (for the various modules) gives a blank response.

There are some admin functions working. The configure ajax interface is empty (no ability to configure ajax).

Yes, I have run the rebuild and repair functions (at least 300 times in this past month… I spend my day clicking repair, dreaming and hoping that it might do something one of these times).

A solution would be appreciated, thanks for your time for anyone who can respond.

If not, some alternative CRM recommendations would be great too.

Hi Homer,

That doesn’t sound great, hopefully we can help!

Please list your full setup, errors in your error.log/sugarcrm.log files and maybe a screen shot of permissions?

Kind Regards,


I am on an apache server, currently php 5.4.

The log file has no entries since the pages all went blank. The most recent are (previous to this issue appearing):

Fri Aug 1 12:47:55 2014 [6855][1][FATAL] Caught error: touch(): UploadStream::stream_metadata is not implemented!
Fri Aug 1 12:47:55 2014 [6855][1][FATAL] Caught error: Non-static method LogicHook::initialize() should not be called statically
Fri Aug 1 12:47:55 2014 [6855][1][FATAL] Caught error: Non-static method Tracker::logPage() should not be called statically
Fri Aug 1 12:47:55 2014 [6855][-none-][FATAL] Caught error: Non-static method SugarConfig::getInstance() should not be called statically

Permissions attached.

With respect: if you are not an IT professional then you are going to be challenged.

Either wait for a few days until the saas product becomes available or go to bitnami and grab a one click installer.

The software is not buggy, it does require knowledge of a complex interlocking ecosystem that comprises of operating system, interprative language and database server … a lot for the non expert to absorb.

But if you are up for the challenge then keep asking questions … you will learn an awful lot.

Just … don’t blame the software :slight_smile:

Appreciate you replying…

We’ve tried this on an IIS box, and a Linux box. Each installation had their own unique issues (different between boxes, but nothing just ‘worked’). Stock installations, no mods… buttons that say “undefined” instead of proper labels. Missing buttons. Erratic ajax functions, missing ajax functions, can’t create dashlets or tabs… this is on stock installations on two different servers.

Once we start customizing or adding functionality the list is understandably longer (no problem there). We can critique our level of expertise (which is admittedly moderate), but we haven’t had this much trouble with other open-sources.

Thanks for your time, the few times I’ve posted feedback has been quick. Unfortunately, no real starting points yet though.