No UI after installation

I have just done an installation to Siteground server. It all went well but when I go to the SuiteCRM directory all I get is

a vertical menu with no user interface showing.

Any help would be very welcome.

Regards, Chris.

1 Like

Hi @cgwhite,

Welcome to the Community! :tada:

Try clearing browser cache, if not check your permissions have been set correctly.

Could we get some details about what system your using?

1 Like

It seems an issue of file permission on cache folder. Here are some tips for set up correct file permission.


Thank you for your reply. I am using the latest version, downloaded a couple of days ago.

I have now managed to get the UI up and running by re-doing the permissions on the system. But, now if I go to my profile and change to one of the different themes the same thing happens.

The information in the Admin Guide for installing the system is not any use when you are using a hosted system. I have a SiteGround account that gives me access to change the file and folder permissions using file manager similar to the old cPanel, it even lets me do it recursively, which I have done as per the instructions. You are currently giving the instructions to change permissions from the linux console but I suggest that most people installing nowadays will be using a hosted system such as the one I am using.

It would be very useful if someone could rewrite the user manual from the perspective of a hosted system.

Any further suggestions on how to get the alternative themes to work would be very helpful.

Regards, Chris.

P.S. I have now solved this issue. When changing to the new sub-theme for the first time the UI does not show correctly. (As in the screenshot I have uploaded). If I go into the cache folder and reset the permissions on the themes folder to 755 it all works. The sub-theme folders are created with permissions of 740. Why is this?


Same here. I have been uninstalling root, deleting and creating database and username - then just decided to also test to have all folders in 775 permission. It’s still the same. I can not also access via SSH just to get all those set up. Have you found what fixed yours?

same issue, all steps completed. No UI