No saving confirmation

I noticed that there were no confirmation of “save” or “save and deploy” in studio, in studio>contacts>layouts>Detailview and same for editview, after one makes changes to the layout and clicks save, the changes do commit but there no confirmation of save, so one is not sure if it has saved properly or if the save button should be pressed again in case. Same goes for save and deploy button, this does nothing and doesn’t even close the window to take you back to the layouts screen.

One time i pressed save a few times and suitecrm froze, not even the breadcrumb menu worked to take me back to layouts.

I also noticed a similar thing when saving user roles, the save button gave no indication that it saved nor did it exit the window.

I am using theme R and have Suitecrm ver 7.2.1 on a shared hosting linux server with cpanel, I tried both firefox and chrome browsers both on laptop and android tablet. I also tried setting file permissions to 664 and folder permissions to 775 as usually recommended. Repair and rebuild did not work either, neither did rebuild of the theme.

Have you tried this when switching back to the old Suite7 theme(can be done in your user preferences). Is this a global issue for you?



Hi WIll

This is not a global issue, just in certain areas such as roles and studio. I tried switching to theme 7, but this was even worse,when in contacts>layouts one cannot even click on any of the detailview, listview etc icons, nothing happens when you click on them. At the bottom of the page was a “javascriptvoid()” error. I then tried repair and rebuild and I cannot get back into suitecrm, instead of the login page I get a completely white screen.

Sounds like you need to set permissions correctly globally.



Hi Will, do you mind detailing for me what the correct permissions should be? I thought I already corrected the permissions as mentioned earlier in my post, I did this via FTP using smartFTP and its recursive feature.

I also edited config.php file permissions string to 775 for folders and 664 for files.

sudo chown -R owner:group .

sudo chmod -R 755 .

sudo chmod -R 775 cache custom modules themes data upload config_override.php

Where the owner/group user is the user for your webserver(apache, www-data etc).

Thanks so much Will, just two last questions if you would kindly indulge me:

  1. I think I have previously read somewhere that permissions 755 and 775 not restrictive enough to be used on the entire SuiteCRM install folder on a public facing hosting platform, especially a shared one; therefore are the permissions you indicated above for a LAN server setup or are they suitable for a web server as well?

  2. The only way I can currently update permissions is using an FTP program like SmartFTP, but it takes very long on a slow connection. I wanted to use a script instead to run daily on a cron job and have tried various permutations of a chmod script and keep getting a Internal Server Error 500 when I try to run it on the shared hosting (linux/cpanel) server. Is there something I am missing or is it not possible to run such a script on a shared server? (I have also emailed the hosting provider this same question.)

Thanks again for your valued time.