No mode Specified error when trying to install french package on Windows Server 2012 R2

hi, i’am newbie, as i motioned in the title, i have a No mode Specified error when trying to install french package on Windows Server 2012 R2, i’am using xampp as a web server. i searched on the web and i couldn’t find some thing that work. :frowning:

i’am using suiteCRM 7.8.3

thank you for your time.

  • On your actual issue:
    Is your XAMPP server working fine for SuiteCRM? You could work with SuiteCRM without any problem
    Only then you will install a language pack.
    See tutorial in my signature below

  • Just for curiosity:
    If you are using windows server why not installing SuiteCRM in native Microsoft IIS?
    XAMPP is just to test things when we don’t have a real server!
    Also its easy to run into collisions if the Microsoft IIS is running at the same time that the XAMP (usually php and mysql ports issues)

Thank you for your replay;

xampp is not so fine, for security issues the server can not be connected
to internet(it have missing modules like PHP and Mysql) , so i installed it in xampp, but after some reshearch, i
found that there is a possibility to download the necessary
Modules and install them offline on the server.

but still i’am afraid that after all of this, the “No mode Specified” error still persist.

I never seen the problem you are reporting (using xamp, wamp or IIS server).

You didn’t replied to my questions:
1- Is SuiteCRM installed and working fine (whatever the server system is)?
2- Language pack is a module to be installed inside SuiteCRM (using Module Loader) did you followed my tutorial?

1- suiteCRM is installed in xampp, and it’s working fine, but the module loader show me that error when trying to install the french package.
1- now i’am trying to install it on IIS as well, but it shows some permission related warnings( i’am working on it)., of course both servers are separated, i don’t run them both in the same time.
2- yes i followed your tutorial, the problem is in xampp, i can not install the package, it gave me the error.

So this can be related to your PHP.ini file settings
You should also verify your suitecrm logs

i configured the file as follow:
->max_execution_time= 600
->removed de “;” from php_imap.dll
->upload_max_filesize = 10M

the log don’t seem to work, it has some informations from the setup phase.
it gives me this error repeatedly:

[5672][-none-][FATAL] Query Failed: SELECT id FROM aow_workflow WHERE aow_workflow.flow_module = ‘ACLActions’ AND aow_workflow.status = ‘Active’ AND (aow_workflow.run_when = ‘Always’ OR aow_workflow.run_when = ‘On_Save’ OR aow_workflow.run_when = ‘Create’) AND aow_workflow.deleted = 0 : MySQL error 1146: Table ‘suitecrm.aow_workflow’ doesn’t exist

P.s: the aow_workflow table and all of the attributes exist.

What XAMP version are you using?
What PHP and Mysql versions are you using?
I have an old xampp version (v2.3.1) for test old sites with older php/mysql versions and it works for me.
Sent you my Xampp config files (for APache/php/mysql)
(note they are not optimized for SuiteCRm work or for security)
Using Winmerge you can compare mine with your files and adjust if needed

  • Restart XAMPP to apply changes!

Note: For testing I do prefer to have Wamp
Similar to Xampp but it allows me to install and switch from different PHP /MYSQL versions with easy

Thank you, i will use your files to optimize mine,i’am using XAMP v.3.2.2.

I installed suiteCRM and the french package in my laptop just to see what happens and it works without any problem, i think that i have some privilege issues in my Windows server.

i have found the solution :lol: :lol: , please do not use internet explorer to install modules or packages.

i hate that browser :angry: :angry: