Newsletter campaign clipped messages

Hello everybody :slightly_smiling_face:

I’m sending newsletters using campaigns module of SugarCRM. And I noticed that in Gmail the message is not fully visible. It is cropped ant at the bottom of the message it is written “[Message clipped] View entire message”. After clicking “View entire message” the new browser tab appears and the newsletter is fully visible… My newsletter is quite long (and I can’t shorten it, because I have there announcement of upcomming events and so on). So I tried to figure out maybe my html code is not optimized. So I found system. I pasted there my html code of the newsletter and sent the test email from that system. In the inbox it appeared perfectly, not cropped. It is an option to copy the HTML (optimized) from So I did it. But from SugarCRM campaigns the same optimized HTML was send with “[Message clipped] View entire message” at the bottom of the email…

I guess the problem is with campaign module or settings of SugarCRM. Did anybody have similar issue and maybe could advise me how to solve it?

I’m using:
Version 7.10.5
Sugar Version 6.5.25 (Build 344)

I used something similar to on my PowerReplacer add-on, to optimize the way the HTML is coded for the email.

Your problem is email size, in KB. That’s what causes Gmail to cut it short.

Have a look at your CSS - if you’re using a big included CSS file, that takes up a lot of space, and chances are that 95% of your styles aren’t even used. I’ve seen a case like this in real-life. Just cut the CSS down to the styles that are referenced in the HTML, and dozens of KBs go away, leaving you with more space for actual content.

1 Like