Moving SuiteCRM from one host to another - SQL problem...

We’ve recently moved our websites from one host to a new host and we seem to be facing a bit of a problem with suitecrm just wondering if anyone knows what on earth is going on.

The error we keep getting up is that it can’t connect to the sql database due to the login name/database name/server being incorrect. Obviously I know that when moving websites from one server to another things like database names and usernames/passwords changed and so I’ve manually updated all of this information in the config.php but still nothing.

We’ve also got Joomla running on the site and transferring that was easy enough, we just changed the username/password/db name and log/tmp directories and off it went (server is still set to localhost).

I also tried just doing suitecrm as a fresh install to see if that would progress, and that also got to the point of accessing the database and again came up with the error that it couldn’t connect to the database. I even tried creating an extra database and checked the username password (even used a very simplistic password just in case it was a password issue as the original password had symbols in it and I wondered whether one of them could be interfering with the config code.

I’ve installed suitecrm on my local wamp to check out if everything transferred properly using wampserver64 (with apache/mysql - my host is using apache/mysql too), and that worked fine, it just doesn’t seem to want to connect to the database on the new host - this is the settings we have (I’ve #'d out certain information)

‘dbconfig’ =>
array (
‘db_host_name’ => ‘localhost’,
‘db_host_instance’ => ‘SQLEXPRESS’,
‘db_user_name’ => ‘####’,
‘db_password’ => ‘####’,
‘db_name’ => ‘####’,
‘db_type’ => ‘mysql’,
‘db_port’ => ‘’,
‘db_manager’ => ‘MysqliManager’,
‘dbconfigoption’ =>
array (
‘persistent’ => true,
‘autofree’ => false,
‘debug’ => 0,
‘ssl’ => false,

probably a permission issue of the user and database, check if the user for SuiteCRM has the correct permission to it database

best regards

I’m having the same issue. Does each user need to have permission to access the DB, and if so, is that automatically created when a new user is created in suitecrm?

It was more than permissions for me. It was so many things that needed to be updated, much like a new install.

I have it (mostly) working, albeit I’m not seeing buttons to remove or inactivate modules, so I can’t uninstall or turn “off” modules that I loaded.

Any ideas?