Moved SuiteCRM to new VPS with PHP 8 - Pukes all over it. 🤮 [Version 7.12.8]


Pretty much as said in the subject headline. When we turned on PHP it just instantly generates 500 internal server error.

But when we switch to PHP 7.4.77 SuiteCRM starts working fine again.

Any ideas about this and maybe how to fix it? :thinking:

Thanks in avance! :+1:

Make sure you have installed all modules for php 8.0 and follow all the recommendations (include configuration of opcache).

I’ve checked and it seem that I have them enabled (The required PHP modules) so I don´t sure know why SuiteCRM doesn’t like the (new) environment on this VPS.
The old VPS used C-panel which we used to partition the virtual server into different functions, but this new VPS have Plesk CP instead.

Here is the global admin PHP settings in Plesk for the whole VPS and everything is turned on:

Any ideas?

What about permission?

There’s another person here on the forums with the exact same problem, and it’s also on Plesk

Well it does work fine on php 7 but of course that isn’t optimal.

I’m no super coder so I’m having a hard time to figure this one out. Did you see anything in the server log that I shared through that might be some kind of clue / lead?

Thanks in advance.

There is error: “Call to undefined function opcache_get_status()” in log file.
Check opcache information: PHP: Installation - Manual

1 Like

Try adding a text file with these contents on your web server root:


Save it as info.php, for example. Now fix ownerships and permissions to make it readable and executable by the web server, then you should be able to access it from a browser, something like:

In the results you get, you can examine which modules exactly are loaded and activated, and also the path of all php.ini’s involved in your configuration.

Focus on things related to opcache both in the modules and the settings. You can contrast with the results from PHP 7.4 to spot any difference that looks relevant.

1 Like

Hi, Plesk seems to explicitely disable the opcache_get_status method by default.

The following forum post on the plesk forum shows a solution for this. Can you try this out?

1 Like

Thanks guys. You all given me some leads of ideas that I can look into during xmas.

Oh and merry Christmas to your all! @p.konetskiy @jansiero @pgr :heart: :christmas_tree: :santa: :deer:

Kind regards

1 Like

Hi guys.

Thank you so much everyone for your help. :heart:
I can confirm that removing “opcache_get_status” in Plesk on domain level resolves the whole issue and after that SuiteCRM runs fine on PHP 8.

Kind regards

1 Like