Module uploader - blank page


After installing the Dynamic Dropdown addon, the Module uploader became blank. I only see the title of this module, nothing else. I would like to upload the portuguese language pack and new themes but first I need to solve this.

Help needed, please…

Thank you,


Did you install this on SuiteCRM? and What DynamicDrop down add on was it the urdhva-tech add on.

is there anything in the logs ? sugarcrm log, php error log ?

Hi Ian,

Yes, I installed it on SuiteCRM and yes, it is the add on from urdhva-tech add on.
I found this error repeated dozens of times:

Mon Dec 1 16:35:34 2014 [712424][1][FATAL] Caught error: Non-static method LanguageManager::loadModuleLanguage() should not be called statically


I have not seen this error before, but there is a chance that this could be causing the problem. have you checked the server logs ?



No, this is an installation on a shared server. I’ll ask for more information to the hosting company.

Thank you.


Your other option would be to add a line to the index.php file temporarily

<?php ini_set('display_errors', '1'); This should display the errors onto the page might might help pin point what is happening when the module uploader is loaded. Ian.

Hi again,

I did it and I got this message at the SuiteCRM homepage:


I am now waiting for the answer to the ticket that I opened on the hosting company support site




That was a bit of a long shot I have to admit. looks like SuiteCRM does not like the errors being outputted on to the screen for that page. Will need to hope that the error log from the server shines some light.

I would remove that line from index.php now.



I already removed that line.

My deduction is:

  1. After all, this problem has nothing to do with the Dynamic Dropdown, it works perfectly;
  2. The problem started with the installation of the language pack.

However, I have searched for the file in the server but couldn’t find it.

Do you have any suggestions?

Thank you,


Hi Ian, hi everybody.

I received an answer from the hosting company that might help (even though, I’m a Political Science guy, so this is very complex for me).
They say that the error could be in method loadModuleLanguage() because it has not been declared “static” ( code ), in utils.php:

function loadModuleLanguage()

should be changed to

public static function loadModuleLanguage()

A few minutes later they wrote be again saying that the function loadModuleLanguage() does not exist and I should consider the solution pointed out at:

Actually, this is too much for me. I would appreciate your help

Thank you again.


try going into admin->Languages and disabling the installed language

i would say

have you check weather its working with sugarcrm 6.5.x

because once i have tried to install sticky notes plugin from the urdhva-tech

which is working with sugar6.5CE with draggable option
but the same addon its not working with draggable option in suite crm

basically if the addon is perfectly developed and if its working with sugar6.5.x than it should also work with suite crm


The add on is working perfectly with Suite CRM. At least I do not detect any issue.
On the other hand, I cannot disable the language pack because I can’t find on SuiteCRM installation. Not in language menu, nor in the language folder…
Should I disable/enable Dynamic Dropdown?


HI ,

let me install and check with that

if you are looking for dynamic drop down you can follow this link

make address field --> dynamic dropdown


Hi adr,

Have reached any conclusion about Urdhva-tech dynamic dropdown add on?
I must confess that your suggestion (link) scares me a little bit. This is not my domain. But if there is not another option, I’ll do it.

Thank you.

Hi luis

i have tried the same thing

i downloaded the add on from this link dynamic-dropdown ( Suite CRM )

uploaded from the module loader and check with the add on its working din’t gv any error to me you can check the screen shot

after that i downloaded the language pack from this link User Friendly Polish Language Pack

and follow this link to apply it install and apply language pack

and that’s it it worked !! i hope you have follow the same way

Thank You for your Time and support !!

Problem solved!

I thought that I had a file permission issue, but I was wrong. The hosting company found the solution here:

And now the problem is solved, no blank page anymore.


1 Like