Marketing Campaign - View Status - Graph fail

Hello Guys

I’m not sure if this is a permissions issue or something with 7.2 but since upgrading when we run a marketing campaign - everything goes through fine - just when clicking “View status” the page “Fails”

There is a large white space where the graph is - but all the sub panels are there with all relevant information inside of click thru & viewed etc

Thanks again

Hi Taufique,

I would run through checking permissions, doing repairs etc. and then check your sugarcrm.log if you are still experiencing issues.



1 Like

we too, have been having issues with status graphs being incorrect. Seems it’s been happening since our upgrade too. Although ours are populated, they are showing incorrect information for different emails within that campaign.

So Will, when you suggest “checking permissions, doing repairs etc. and then check your sugarcrm.log” What does that mean or what would I be looking for?


I would think that bad file permissions could cause the graph to not show.

The Repair and Rebuild option within the admin section would be best to run and see if that changes anything.

within the instance there is a file sugarcrm.log which contains the logs for the instance,


I am having the same issues. Although, it is my first time that I run a campaign on 7.2.3. Scheduler is running, inbound emails are being parsed. All scheduled cron tasks are running, accept for Reports. No reports defined either.

Advise on this issue would be greatly appreciated. Thank you in advance.


Hi again,

When clicking on View Status in the runned campaign I get a Fail dialog box (screen shot attached) twice.

I did a (1) permissions check, all seems ok. Did a (2) Repair and Rebuild. Checked the (3) sugarcrm.log file, nothing since Jan 2014. Checked (4) error_log file and found the following:
[08-Aug-2015 14:15:23 America/Chicago] PHP Warning: Invalid argument supplied for foreach() in /home/sgadmin/public_html/crm/custom/modules/Administration/AOPAdmin.php on line 142
[10-Aug-2015 17:40:44 America/Chicago] PHP Warning: array_keys() expects parameter 1 to be array, null given in /home/sgadmin/public_html/crm/include/Popups/PopupSmarty.php on line 391
[13-Aug-2015 16:27:28 America/Chicago] PHP Fatal error: Cannot redeclare class OAuthToken in /home/sgadmin/public_html/crm/custom/modules/Connectors/connectors/sources/ext/rest/spaces/opensocial-php-client/osapi/external/OAuth.php on line 25
[14-Aug-2015 07:08:34 America/Chicago] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home/sgadmin/public_html/crm/include/phpmailer/class.smtp.php on line 464
[14-Aug-2015 13:40:03 America/Chicago] PHP Warning: readfile(modules/AOR_Reports/css/edit.css): failed to open stream: No such file or directory in /home/sgadmin/public_html/crm/modules/AOR_Reports/views/view.edit.php on line 38

Again, advise on this issue would be greatly appreciated. Thank you in advance.



The View ROI Graph does work!

It appears that my Web To Lead Campaign created a while ago (version 7.1.x plus) does show the View Status normally. A new email Campaign created early August however, I get the fail and failed dialog boxes.

Im having the same issue when click “view status” in a Campaing using version 7.4.3

has there been any updates to this?

I just tested it. It works now, after I have upgraded to 7.4.3, I assume.