ListView Column Filtering not working

I recently updated from 7.7.8 to 7.8.2, which added the column filtering option per user. It hasn’t worked at all so far, and am hoping to get more information on where the new files and code for that feature can be found so I can repair it.

There are no errors in the log when trying to save a filtered column set per user, so it is very difficult to know where to begin looking, and identify the files that are missing.

I installed a fresh version of 7.8.2, and the filtering works there just fine. So it seems to have been an issue with the update (which didn’t throw any errors or indicate issues of any kind).

I’ve been digging around trying to figure out what is missing and what went wrong during the update. I know the data is saved in the user_preferences table, in a base64 encoded JSON object in the ‘content’ column/field, along with other user preferences and customizations. Can anyone help and at least point me in the right direction or help me to figure out what files are broken/missing?

Is nobody else having this issue, and can nobody from SuiteCRM suggest anything?

Having the same issue. If I use filter the columns go back to default columns


I am also facing same issue. Can any one help us to resolve this issue.

Still no word from anyone with this?

Surprised just a couple of use are having this issue, which makes the new additions unusable… I have looked through the utils.php file, and the UserPreference.php files, and cannot identify anything that looks out of place when compared to a fresh install’s files (which is working).

It’s almost as if the update that added these features missed files, but I cannot identify where. Any advice or suggestions

Having the same issue. Can someone assist?

I am also having this issue. Admin can filter Leads etc but users can’t. When they click the filter button nothing happens.