Language options at login

I just upgraded to 7.4.4 using the new Suite P theme and at log on I get this drop down menu choice for language. Is there a way to make that disappear? It does not go with the new theme and is a pain to choose each time. Thanks!

if you disable other language and set one as default you won’t get that option there, you need to set this in System Config

best regards

Thanks for the reply Mike. So, I need to edit the config.php file? I’m new to SuiteCRM and am learning on the fly.

Not necessarily, you need to go to Admin->System->Locale to set a default language and in Admin->System->Languages you can drag to Disabled Languages the ones that you don’t need

best regards

Thanks again Mike. Admin System Locale… no problem. Interestingly, when I go Admin System Languages… I have no choices… just the below. I’m assuming there should be more?

Drag and Drop the names of the languages below to enable and disable them.


So you’re saying that you get a prompt to select language in log in screen but you don’t have other languages than the English one?

best regards


On log in I get an option with a drop down window for ENG, RUS and ES

When I go to admin languages, there are no choices

This is from the config.php file…

‘js_custom_version’ => 1,
‘js_lang_version’ => 5,
‘languages’ =>
array (
‘en_us’ => ‘English (US)’,
‘es_es’ => ‘Español (ES)’,
‘ru_ru’ => ‘Русский (RU)’,

OH! I see, well there’s something wrong in your SuiteCRM instance because in the second screenshot that behavior means that something didn’t load, can you run a quick repair the rebuild, also Repair JS, and try to remove those hardcoded from old version of SuiteCRM

best regards

Repairing now.
How would I remove the hard code? edit the config.php file?


after the error should be sought that will not be the only place could be missing at the entries. Check Permissions, PHP version etc.

The cut-config.php is correct.

With these two parameters you can exclude the selection:

‘default_language’ => ‘en_us’ ,
‘disabled_languages’ => ‘es_es,ru_ru’,

Repeat this in the config_override.php

It looks an old instance, the time languages where not installed but included in the zip.
Editing the config.php file works but is a workaround.
When upgrading old instances I do prefer to have it the normal way and not use the disabled languages.
1- Make all languages enabled on the language users config
2- Make sure there is no other disabled languages in config.php file
3- Download and install the languages that show up on the login menu (use Module uploader) so they can be managed by the language installed screen
4- Uninstall the languages I do not need (so there is no need to hide languages in the config file)

This way they you get a clean language files, no unused translations and the system works fine.
If in the future you will need an extra language I’m pretty sure you will need to install a recent language pack as translators do not sleep! :slight_smile: