Issues with Installing SuiteCRM 8 on ubuntu 20.4

Hello Guy’s,
Greetings, I am facing an issue with insta;lling suitecrm 8 on ubuntu 20.4.
download zip and upload on server.
Git command was not working for SuiteCRM 8.

After code deploying set permissions as per documentation.
find . -type d -not -perm 2775 -exec chmod 2775 {} ;
find . -type f -not -perm 0644 -exec chmod 0644 {} ;
find . ! -user www-data -exec chown www-data:www-data {} ;
chmod +x bin/console

and tried with suuitecrm 7X permission as well.
not any good luck…

installing page not showing anything.
Please help .

Best Regards,

Thanks in advance

Hi @shatty128,

Thanks for trying out SuiteCRM 8.

We’ve seen this error happening when there is some misconfiguration in mod_rewrite.

Could you double check if you have mod_rewrite active?

Also please check if your vhost configuration is set to allow overrides. Adding an example next:

<VirtualHost *:80>

    DocumentRoot /<path-to-suite>/public
    <Directory /<path-to-suite>/public>
        AllowOverride All
        Order Allow,Deny
        Allow from All

I think the issue you are having is the same as the following, you can find more information here:

Hope this helps

Thanks Clemente for response. Let me try .

All issues resolved
but still i am facing an issue with installation .
1: console.logs empty , public/legecy/suitecrm.log is empty as well

2: installing from the command line and showing UPLOAD_MAX_SIZE at least 6 MB but that’s 200MB

3: apche2 configured

checked this issue as well but not resolved

attached files

Hi @shatty128,

Great! glad you were able to make some progress.

Regarding the errors you’ve described:

1. Install page validation error
For the error in the install page. You have to select a value for Populate database with demo data, either yes or no.

By the way, you can use either the install page, or the command.

2. Cli install system check warning

For the cli install you can also ignore the system check warning by passing -W true

  • Notes:
    • You can run ./bin/console suitecrm:app:install --help to see all the available options
    • On the limit warning, this error can happen if your apache is using a different php version from the one that is used by php in the terminal. Different versions will have different .ini files.

Hope this helps.

Extra note:

We are in the process on updating the install documentation on docs.suitecrm. We tried to make the documentation more thorough in order to avoid the most common problems being raised.

Hi @shatty128,

We have just updated the SuiteCRM 8 install documentation. The updates try to make it more comprehensive.

I think it may help a bit more now:

Please let me know if you still have issues