Internal Server error

Hi forum users

I have CentOS6 & CentOS7 both x64 fully patched installed as VM in bridge networking mode on my laptop.

All prerequisites are installed all updates to linux is installed
Web / mysql / php server are installed
I class my self as reasonable to linux user
I have read all documents for installation

But no matter what I do, I start installation process, works fine, but up to the point when I reach on 2nd last screen where last option is populate test data in DB, I click next, I get all is done.

I click next I get internal server error
just to make sure that server is working fine, I create another virtual server & install phpbb to test it works & works perfectly fine.

Later I found that permission of suite crm folder should be 755, & I have checked that permissions are 755 on main folder & all files & subfolders.

my web url to VMs is

I have created a VHOST entry for crm & then there is a sub folder crm on VHOST document root.

I have checked & confirmed that my host file is correctly pointing to correct IP

IPTables is disabled, no other security software is installed.
SELinux is disabled
I have tested other php / java based software such as phpbb & kibana on same VM server, works perfectly fine side by side but when I type I am getting internal server error.

Can any one please help & guide what is wrong, what I am doing wrong & where, I have spent almost now two days on this, but no luck on both VMs CentOS 6 & 7

I am evaluating this for our office use, but want to test it 1st so learning it 1st, but nothing is progressing because of failed install.

I am now of opinion if installation is that hard, usage must be another nightmare.

I am wondering what other user think about this installation process. there is no clue anywhere

Set the permissions on all files and folders in the crm directory to 777 temporarily and try installing it again. Also which version of php are you using and is error reporting switched on? Look in your error php log for potential errors that might be causing this problem.

Thank you Andy for advise,
Following is update

  • PHP version current version = 5.6.5
  • PHP version I have tested with = 5.5.21
  • PHP version I have also tested with = 5.4.37
  • MySQL DB current version = 5.6.23
  • MySQL DB I have tested with = 5.5
  • My SQL DB I have also tested with - 5.1
  • Apache 2.2.7 I have also tested with 2.2.x but older then 2.2.7 versions
    CentOS version 7 x64 fully patched, I have also tested with just un patched version, same applies to CentOS 6.5 x64

As per your suggestion I have done in both chmod permissions, i.e. 777 & 755, orignally when I unpack its 777, but tried with 777 & 755 for config.php I have also tested different permissions, i.e. 777, 755 600, 700.

VMWare workstation 11 on my laptop
memory 16GB
allocated memory to VM = 6 GB
php-imap is installed
php file upload limit is also increased to 99 MB
php process memory is set to 128 MB later increased to 256 MB

orignally apache virtualhost entry was pointing to document root & then crm folder was inside document root, now I have altogether tried to install it on document root itself.

on linux DNS name resolution is set & working fine
on my laptop c:\windows\system32\driver\etc\hosts entry is correctly pointing to Virtual machine
I have tried to install phpbb & Kibana on same virtual machine in parallel both works file no issues, I have not received any internal server error.

Why I am using CentOS7 because we have subscription for RedHat Enterprise server, once I am ready to deploy in production environment, I will be using Redhat 7, so just to be sure that its not CentOS 7 issue, I have also tested this on RHEL 7 x64, same issue.

So for all my efforts failed, I cannot possibly think of any other option, other then that I change OS platform from CentOS / RHEL to SuSE or Ubuntu etc.

Any help will be appreciated.


Can you look in your php error log and see if there are any errors showing?