Installation stuck on step 2/2


I am trying to install suitecrm on a centos 7 machine. I am using an apache webserver and running PHP Version 7.1.30.

When I run the installation, I can get to step 2/2, but it gets hung up on:
Creating the database suitecrm on localhost…done

However, it says “done”, but when I go to look at the db, there are no tables or anything created in the suitecrm db.

When I check the log files, I can see the last command called was “handleDbCreateDatabase()” Any help on this would be much appreciated!

Also, another issue, but could be related. The logs are not printing to install.log, but suitecrm.log. In the log files it says “[FATAL] could not open/lock install.log file” or "[FATAL] could not write to install.log: "

I have the install.log file own by apache user and group. And have tried with both 755 and 775 permissions on install.log.

Please let me know if any other information would be useful and I can provide.

Thanks in advance for your help!


Can you please make sure which user your Apache is running under? Try this

ps -ef | egrep '(httpd|apache2|apache)' | grep -v `whoami` | grep -v root | head -n1 | awk '{print $1}'

Then give the full permissions settings (change the user and group to what you got from the command above:

  cd [/your/suitecrm/directory]
  sudo chown -R apache:apache .
  sudo chmod -R 755 .
  sudo chmod -R 775 cache custom modules themes data upload
  sudo chmod 775 config_override.php 2>/dev/null

The apache user is ‘apache’, verified by your command.

I ran the permission settings commands you suggested and still have the same result. I am still seeing the “could not write to install.log” and the process is still stuck at the commands “handlDbCreateDatabase()”

I did do the permission setting prior to your suggestion as they are in the install docs. I re-ran them now for sanity reasons.

Is there anything else that could be blocking access? For example, a web server configuration like .htaccess, or some other security software?