Inbound mail account setting, no response

Sending mail ok, but the testing of inbound mail account stuck without any response. Hours spent.

you need to provide your SuiteCRM version, system os, php version, mysql version, etc. Also check your webserver and suitecrm logs

best regards

SuiteCRM7.7.7, Windows 10, PHP5.4.45, MySQL5.5.53. Log file once showed “11/16/16 06:17:05 [8628][-none-][FATAL] Configuration variable date.timezone is not set, guessed timezone UTC. Please set date.timezone=“UTC” in php.ini!”. I fixed it by setting the timezone in php.ini. No fatal errors were reported in log file after that.

After I fill out the incoming mail setting, and chick ‘test setting’. There is no response at all. The setting interface becomes gray and disabled.
Any more informtion requred to identify the cause?

do you have the imap extension enabled? is there something in suitecrm.log?

best regards

IMAP extension? I think it is enabled. The phpinfo() says “IMAP c-Client Version 2007e” and “SSL Support enabled”.
I tried the inbound mail setting again and again. There is no errors in the log. Anyone let me know whatelse I have to try.

Hi mikebeck,
Just answered your question if the imap is enabled and any error in the log. IMAP is enabled, and no error in the log.
Well, I use the method described
It is found that the connectivity to mail server is ok, but the return shows the total number of messages is 0.
Actually it is not 0. Anything wrong? Can it cause the ‘test setting’ not working?

Problem solved. The imap requests sent by SuiteCRM were rejected by the mail server. The problem is solved by changing the setting of mail server.
But, the problem was identified through another email app which provides error information.
Hope an error information can be provided in case the requests are rejected by mail server in further updates of SuiteCRM.

hgq: can you explain in clear detail what you did to solve the issue so that others can benefit too?


I have been using NetEase ( with imap activated.
But, until recently, I didn’t find imap alone doesn’t work on “unknown” clients.
For “unknown mail clients”, you have to login using the “authorization code for mail clients” rather than the login password. Well, users are not asked to set such a code when they register the mail service. It may be ok in many cases where login by password.

So, when someone has a similar difficulty, he may go to the mailbox, check settings for any “code” required for mail clients. If it does, set the code, and login with the code not the code.