Inbound email takes a very long time to create cases

HI all,

We have the inbound email setup to create cases and then distribute it to the team. The logic works fine, but the problem is with the time it takes to download mails and create cases. It currently taking 15 minutes to create cases for the new mails. Its started with once a minute and then gradually increased the time to complete the job to 15 minutes. Is this normal behaviour? Has anyone faced this issue and know a fix for this?

Have tried restarting the system, inactivating/reactivating the scheduler, and have also made all the emails in the inbox as read. Nothing seems to work.

Any help on this is greatly appreciated.

Please start by checking how often your cronjobs are runnning. This depends on 2 things:

  • the schedule for launching cron.php from your Linux crontab

  • the schedule of the specific job in Admin / Schedulers (I believe it’s “Check Inbound Mailboxes”)

If that’s not the issue, then start looking for slow queries. You can turn on “Log slow queries” in Admin / System settings and then check your logs after some time.

Finally, you may be in need of some database maintenance. Run the first query in this post and see if you have any overgrown tables:

Thank You.
Am sure its not the first two points that you mentioned as that has been checked. Will have a look at the other two point you have mentioned.


I see an issue already logged for this on GitHub
Inbound email - only_since - flag missing #7172

Hmm that seems a bit stalled. Maybe you can post there to bump it, and add any extra information that you think might be useful.