📣 We're Hiring!

Inbound email loading is very slow

Hi,

I am using default email module to view my inbox emails. But when I load the module it takes so much time to load about 10 mins. I have around 45k emails.

Any suggestions on how to optimize and make it better?
System Specification:
OS - Ubuntu 18.04
CRM version - 7.11.13
PHP - 7.2

Thanks,
Shantanu Agnihotri

Hi,
There must be something which is stopping Email module to get loaded.
You may follow these steps to get understand issue.

  1. Change or remove suitecrm.log file , so that you only see fresh logs.
  2. go to admin -> enable log slow query.
  3. come to Email module and refresh it. it must show you SQL which are taking time in running.

Apart from it, I have writen a blog over performance. If issue does not resolve, you may take a look on that too.



Grab Free Extensions from Outright Store : https://store.outrightcrm.com/free-extension/

1 Like

45k emails is way too much unless you’re really going to get serious about hardware and software performance tweaks.

We easily get used to having a ton of information on Gmail and forget we’re not actually running a full-blown datacenter when we copy that email somewhere else.

Normally there should be a way of using less email, not importing so much stuff and just stick to what you really need to use for your daily processes.

These are the logs I got from log file.