Image fields do not display correctly in reports


I recently ran into weird problem…

I needed to make a change of standard Meeting object, adding a photo of a person to meet with.
Thru Studio I added new field of type “Image”, change appropriately Edit/Display forms and everything worked fine.
I could add image to a meeting, I could see this image in the list view and in the details view.

But then I needed to prepare a list of all meetings as a report.
The simplest report was designed: Name, Date, Time, Image of a person.
When the report is generated, the image is not shown, the url of image source is wrong.

As I understood, it is supposed to contain “id” of the record to show, but due to what I do not understand, this id is empty.

So, I got html source in the report like this:

although it must look like this:

The code for this part of report is taken in

And I literally spend days trying to figure out what can be the reason of that.

Did anybody have a problem like that, and do you have any hints to solve it? I appreciate the help very much!

Tech details:
SuiteCRM version: 7.5.3 (previous versions 7.4.x, 7.3.x gave same result, upgrade did not help)
running on Windows 2008 R2 Standard Edition
MySQL 5.5.39
PHP Version 5.4.4


Thanks for highlighting this issue.

I’ve logged it on our github repository as a bug:

You can track the status of the bug, or add any information you feel is relevant, on the issue page itself.

Thanks again!

Hi again!

I see on that the fix of this issue was done and is available to install.
That is great, I have installed it, and the report display now works perfectly.
I did not expect this to be solved so fast, once again - appreciate it very much.

When testing the fix, I found that the problem still persists if the PDF file is exported.

Images are not included into the PDF-reports, and every field that is of type “image” has “image not found” icon.
No matter if the image was linked to this record in the report, or not.

It looks like the PDF generator treats every image-field as containing image, exports PDF, but PDF generator does not save correct “empty” urls (when there is no image) or does not put correct images for records where they were defined.

I wrote the comment to this issue on github (, but I am not sure that this is the correct way to inform abou this issue. Maybe this is another issue, or it is related to the same question raised in April.

Could you please give a hint on what is to be done for this second part (PDF-related) issue not to be missed or lost…

Thank you in advance

I am running into the same issue with PDF exports. Is there a fix for this?