HTTP 500 error after I save an account, a contact or update any record

I’m getting a HTTP 500 error error after I save an account, a contact or update any record.

PHP version 7.2.32 running on centos.

I’ve ran the following commands a few times.
sudo chown -R apache:apache .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload
sudo chmod 775 config_override.php 2>/dev/null

I have tried the “Quick Repair and Rebuild” multiple times.

I have disabled the: “Validate user IP address”

I’m also getting these errors in the log file:

SugarBean::populateDefaultValues $field_defs should be an array
Cannot find bean file for module: Versions
Cannot find bean file for module: CustomFields
Mysqli_query failed.
Query Failed: select * from versions: MySQL error 1146: Table ‘suitecrm.versions’ doesn’t exist

Hi @jonathanp,

Welcome to the community!!!

Now, a few quesitons:

What version of SuiteCRM are you using?
What is your MySQL version?
Is this a new installation?
Did you added any custom code recently?



Install is a few months old. Has been working fine.

SuiteCRM version
Version 7.11.15

Sugar Version 6.5.25 (Build 344)
SQL version:
MySQLi Version: 5.5.65-MariaDB
MySQLi Host Info: Localhost via UNIX socket
MySQLi Server Info: 5.5.65-MariaDB
MySQLi Client Encoding: utf8
MySQL Character Set Settings: character_set_client = utf8, character_set_connection = utf8, character_set_database = utf8, character_set_filesystem = binary, character_set_results = utf8, character_set_server = latin1, character_set_system = utf8

No custom code loaded.

Did you added any custom field before you start to seen the error. IF you did, please try to remove them and try again.



I don’t believe any custom fields were created. Is there an easy way to check/confirm this?

I believe this has fixed the issue:

disable the AOD from Admin -> AOD Settings.

Good thing you found the issue. Now, the question is Why AOD is giving you issues?

hello, i have the same problem. I have tried all of the recommendations without success. The only one that works is to turn off AOD, but global search suddenly doesn’t work. Do you have a clue to fix this? Thanks in advance Quentin

1 Like

I have the same problem. Did you already resolve?.

No, i’ve downgrade to 7.11.15